Closed Bug 1483190 Opened 2 years ago Closed 1 year ago

Android 4.0 L10n nightlies broken: mozbuild.configure.options.InvalidOptionError: --enable-lto is not available in this configuration

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect, P1, blocker)

defect

Tracking

(firefox61 unaffected, firefox62 unaffected, firefox63blocking verified, firefox64 unaffected, firefox65 unaffected, firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 blocking verified
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: aryx, Assigned: RyanVM)

References

Details

(Keywords: regression)

Attachments

(1 file)

Latest push with Nightlies:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=914b3b370ad059a04ad751642b74e013f8e3ad08&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&selectedJob=193836951

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=193836951&repo=mozilla-central

[task 2018-08-14T10:44:15.929Z] 10:44:15     INFO -   0:02.73 checking for vcs source checkout... hg
[task 2018-08-14T10:44:15.932Z] 10:44:15    ERROR -   0:02.74 Traceback (most recent call last):
[task 2018-08-14T10:44:15.932Z] 10:44:15     INFO -   0:02.74   File "/builds/worker/workspace/build/src/configure.py", line 123, in <module>
[task 2018-08-14T10:44:15.933Z] 10:44:15     INFO -   0:02.74     sys.exit(main(sys.argv))
[task 2018-08-14T10:44:15.933Z] 10:44:15     INFO -   0:02.74   File "/builds/worker/workspace/build/src/configure.py", line 29, in main
[task 2018-08-14T10:44:15.933Z] 10:44:15     INFO -   0:02.74     sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
[task 2018-08-14T10:44:15.933Z] 10:44:15     INFO -   0:02.74   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/configure/__init__.py", line 409, in run
[task 2018-08-14T10:44:15.934Z] 10:44:15     INFO -   0:02.74     self._value_for(option)
[task 2018-08-14T10:44:15.934Z] 10:44:15     INFO -   0:02.74   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/configure/__init__.py", line 477, in _value_for
[task 2018-08-14T10:44:15.934Z] 10:44:15     INFO -   0:02.74     return self._value_for_option(obj)
[task 2018-08-14T10:44:15.934Z] 10:44:15     INFO -   0:02.74   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/util.py", line 944, in method_call
[task 2018-08-14T10:44:15.935Z] 10:44:15     INFO -   0:02.74     cache[args] = self.func(instance, *args)
[task 2018-08-14T10:44:15.935Z] 10:44:15     INFO -   0:02.74   File "/builds/worker/workspace/build/src/python/mozbuild/mozbuild/configure/__init__.py", line 542, in _value_for_option
[task 2018-08-14T10:44:15.935Z] 10:44:15     INFO -   0:02.74     % option_string.split('=', 1)[0])
[task 2018-08-14T10:44:15.935Z] 10:44:15     INFO -   0:02.74 mozbuild.configure.options.InvalidOptionError: --enable-lto is not available in this configuration
[task 2018-08-14T10:44:15.956Z] 10:44:15     INFO -   0:02.76 *** Fix above errors and then restart with\
[task 2018-08-14T10:44:15.957Z] 10:44:15     INFO -   0:02.76                "/usr/bin/make -f client.mk build"
[task 2018-08-14T10:44:15.957Z] 10:44:15     INFO -   0:02.76 client.mk:123: recipe for target 'configure' failed
[task 2018-08-14T10:44:15.957Z] 10:44:15     INFO -   0:02.76 make: *** [configure] Error 1
Blocks: android-lto
Severity: normal → blocker
Flags: needinfo?(mh+mozilla)
Keywords: regression
Priority: -- → P1
Sorry, these aren't builds we actually ship, so downgrading the severity a bit.
Severity: blocker → critical
This bustage blocks uploading Nightly
Severity: critical → blocker
*sigh*

This bustage blocks uploading Nightly APKs to the Play Store. Re-bumping the priority.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d296e62cb8543ec243e44e7bb47113364722e243

And I also did confirm that the L10n job is broken on Try without this patch.
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Flags: needinfo?(mh+mozilla)
Attachment #9000039 - Flags: review?(nfroyd)
Comment on attachment 9000039 [details] [diff] [review]
Only enable LTO if the NDK is available

Review of attachment 9000039 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!

::: mobile/android/config/mozconfigs/android-aarch64/nightly
@@ +9,5 @@
>  export AR="$topsrcdir/clang/bin/llvm-ar"
>  export NM="$topsrcdir/clang/bin/llvm-nm"
>  export RANLIB="$topsrcdir/clang/bin/llvm-ranlib"
>  
> +# Enable LTO if the NDK is available

Nit: Periods at the end of sentences, please.  Here and throughout.
Attachment #9000039 - Flags: review?(nfroyd) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/0fc57261a269
Only enable LTO if the NDK is available. r=froydnj, a=RyanVM
Target Milestone: --- → Firefox 63
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> *sigh*
> 
> This bustage blocks uploading Nightly APKs to the Play Store. Re-bumping the
> priority.

*sigh* android single locale bustage shouldn't break Google Play submission. I'll try to get a bug on file for this, (or someone else can before me, n-i me and jlorenzo)
See Also: → 1483521
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/1507e086acbcf9e0c60cfa7e89dd31995950e520 for multiple reasons (see commit message).
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
I'm going to assume that if/when bug 1480006 is ready to land again, this fix will be rolled into that.
Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1502126
Duplicate of this bug: 1502006
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I messed up the re-relanding of bug 1480006.
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/70b12731ca43
Only enable LTO if the NDK is available. r=froydnj, a=RyanVM
https://hg.mozilla.org/mozilla-central/rev/70b12731ca43
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: Firefox 63 → Firefox 65
Backed out changeset 70b12731ca43 (Bug 1483190) for crashes on Android (Bug 1489553) a=backout

Backout push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&resultStatus=testfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&revision=700e65c0ab9bb8ec1182b890bd51722b95eb0f24
Status: RESOLVED → REOPENED
Flags: needinfo?(ryanvm)
Resolution: FIXED → ---
Target Milestone: Firefox 65 → ---
Backout by ebalazs@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/9d294202030e
Backed out changeset 70b12731ca43 for crashes on Android (bug 1489553) a=backout
That bug number makes no sense. Also, this change doesn't affect any builds we ship, so how can it possibly be related?
Flags: needinfo?(ryanvm)
Flags: needinfo?(ebalazs)
Flags: needinfo?(aryx.bugmail)
Typo in the bug number, my bad. Should be bug 1489953.
Flags: needinfo?(ebalazs)
Flags: needinfo?(aryx.bugmail)
This bug was to fix the l10n/artifact bustage from bug 1483190. And the relanding of bug 1483190 yesterday didn't include it like the previous attempt. And it was backed out again.
Ryan or Mike, what needs to happen here?
Nothing at the moment. Just needs to re-land whenever bug 1480006 is ready for another try.

This was included in the relanded patch for bug 1480006.
https://hg.mozilla.org/mozilla-central/rev/5ab46880d921

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 66 → mozilla66
You need to log in before you can comment on or make changes to this bug.