Closed Bug 1483200 Opened Last year Closed Last year

The Search bar is no longer stuck to the top when scrolled if the Browser's height is under 770px

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- affected

People

(Reporter: cmuresan, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Notes]:
- On a MacBook Pro 13-inch Retina display the scroll bar is never stuck to the top when scrolled, given that the Dock is displayed at the bottom of the screen and pushes the Browser window up.
- The issue will always be present on screens with 1366x768 resolution which, according to statcounter, is the #1 most common screen resolution.

[Affected versions]:
- Nightly v63.0a1, Build ID 20180812220618

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have enough history so that all sections are populated and the page can be scrolled.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites and open a new tab.
2. Vertically resize the browser window to a value under 700px
3. Scroll down the page and observe the behavior.

[Expected results]:
- The Search bar is stuck to the top part of the browser window.

[Actual results]:
- The Search bar is not stuck and remains in its initial fixed position.

[Notes]:
- Attached a screenshot of the issue.
This was by design. The reasoning IIRC is because the user can potentially also have a snippet at the bottom taking a good chunk of their window. It becomes weird on short windows to also have search at the top leaving little space for the content to scroll. Am I right BryanBell?
@Bryan question in comment 1.
Flags: needinfo?(bbell)
Bryan says yes this is by design "also it just make reading the page easier in general for people with tiny screens"
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
Flags: needinfo?(bbell)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.