Black shadow is displayed behind the text in about:welcome page when Dark theme is enabled

RESOLVED DUPLICATE of bug 1462672

Status

()

defect
RESOLVED DUPLICATE of bug 1462672
9 months ago
8 months ago

People

(Reporter: Gabi, Unassigned)

Tracking

({regression})

Trunk
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 unaffected, firefox62 wontfix, firefox63 fixed)

Details

Attachments

(1 attachment)

Posted image darktheme.png
[Affected versions]:
- Beta 62.0b17

[Affected Platforms]:
- macOS  12.6
- macOS 10.11.5



[Steps to reproduce]:
1. Open Fx with a clean profile
2. When about:welcome page is displayed go to Customize
3. Go to Themes 
4. Change theme to Dark
5. Observe the about:welcome page

[Expected results]:
about:welcome page should be displayed properly, no UI issues should occurr

[Actual results]:
Black shadow is displayed behind the strings in about:welcome page when Dark theme is enabled


[Notes]: 
- Refreshing the about:welcome page fixes the issue
- Attached png of the issue
- Not reproducible under Windows, Ubuntu or MacOS 10.14
(FYI: Firefox::General should only be used for bugs known not to have a better component, otherwise filing in Firefox :: Untriaged will have someone move them to the right spot.)
Component: General → Theme
Hmm, the dark theme really shouldn't affect this page at all, right?
Flags: needinfo?(ntim.bugs)
Ah, this page is basically about:home with some stuff added.
Component: Theme → Activity Streams: Newtab
Flags: needinfo?(ntim.bugs)
@erica, could you please take a look at this?
Flags: needinfo?(ewright)
This can only be reproduced on a new profile, and only for a small while. The font eventually re-adjusts itself. When I go to inspect the font in the debugger, this causes a repaint and it automatically changes to appear as expected.
For about:welcome's purposes, I'm not worried about this, it seems like a small edge case. Considering that on the first run the user will have Firefox set to it's default theme.
However, this seems like a graphics bug to me and something they might be interested in pursuing.
Flags: needinfo?(ewright) → needinfo?(jmuizelaar)
This looks like a subpixel aa bug. Thoughts Lee?
Component: Activity Streams: Newtab → Graphics: Text
Flags: needinfo?(jmuizelaar) → needinfo?(lsalzman)
Product: Firefox → Core
This is listed as 61 and 63 being unaffected, which would imply there was a regression and that the regression was fixed by something. If so, could you please use mozregression to narrow down which revision caused it, and which revision fixed it?

See https://mozilla.github.io/mozregression/quickstart.html
Flags: needinfo?(lsalzman) → needinfo?(gasofie)
This is most likely a layers issue. It is either possibly related to bug 1493075 or bug 1473041.
See Also: → 1493075, 1473041
Gabi can you get a regression window?
This was fixed in 63 by bug 1462672.

62 has already been released, and that bug is not upliftable to a point release, so I think there's nothing we can do here.

I found the fix range using $ mozregression --find-fix --bad 20180625100047
with the following STR:
 1. Type about:welcome in the URL bar and press enter.
 2. Open the hamburger menu and choose Customize...
 3. Click on the Themes button and move the mouse upwards.
   3a. If this causes the browser layout to be messed up:
      3a1. Click in the gray space outside to close the menu.
      3a2. Resize the browser window slightly (make it just a bit larger) by dragging the window's bottom right corner.
      3a3. Switch tabs to about:welcome.
      3a4. Switch tabs back to custimization.
      3a5. Open the Themes menu again.
 4. Select the Dark Theme.
 5. Switch back to about:welcome.

Fix range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=85f1c6e5ddac7792b327c05996f8bf27ed728d72&tochange=92bd3b2178623a036ea91990aa5570e039890ff4


Since bug 1462672 added an alternative code path for rendering this case, it's possible that this bug is still present in the old code path. It would need more investigation to find out whether that's the case.
Flags: needinfo?(gasofie)
61 does not have about:welcome. I think that's why it's "unaffected". With the same test page, I'd expect it to show this bug.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1462672
You need to log in before you can comment on or make changes to this bug.