Closed Bug 1483350 Opened Last year Closed 5 months ago

Intermittent devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | Test timed out -

Categories

(Core :: Web Replay, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bhackett)

References

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: nerli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=193908204&repo=autoland

https://queue.taskcluster.net/v1/task/cUrnRU4JRB29Zh582FmKAQ/runs/0/artifacts/public/logs/live_backing.log

10:14:46     INFO - Buffered messages finished
10:14:46     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-03.js | Test timed out - 
10:14:46     INFO - Removing tab.
10:14:46     INFO - Waiting for event: 'TabClose' on [object XULElement].
10:14:46     INFO - Got event: 'TabClose' on [object XULElement].
10:14:46     INFO - Tab removed and finished closing
10:14:46     INFO - GECKO(821) | MEMORY STAT | vsize 4957MB | residentFast 897MB | heapAllocated 153MB
10:14:46     INFO - TEST-OK | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-03.js | took 90377ms
10:14:46     INFO - checking window state
Summary: Intermittent devtools/client/debugger/new/test/mochitest/browser_dbg_rr_breakpoints-03.js | Test timed out - → Intermittent devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | Test timed out -
Duplicate of this bug: 1552673

yeah, this is odd, you did a great job retriggering and show that as a result of the cross merge this is now perma fail whereas before it wasn't.

I would vote for making this tier-2 and m-c only- it appears to be that:
https://searchfox.org/mozilla-central/source/taskcluster/ci/test/mochitest.yml#246

so if that is the case, lets give it 1 week to see if it can be fixed on m-c and then disable it.

The failure looks like:
23:53:18 INFO - Buffered messages logged at 23:52:38
23:53:18 INFO - TEST-PASS | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | Got one source -
23:53:18 INFO - TEST-PASS | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | Source is doc_rr_continuous.html -
23:53:18 INFO - Buffered messages logged at 23:52:39
23:53:18 INFO - TEST-PASS | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | Paused at line 19 expected 19 -
23:53:18 INFO - Console message: [JavaScript Error: "Error: Assertion Failed!" {file: "resource://devtools/server/actors/replay/debugger.js" line: 1162}]
23:53:18 INFO - Console message: [JavaScript Error: "Error: Current thread has paused or resumed" {file: "resource://devtools/client/debugger/src/utils/context.js" line: 35}]
23:53:18 INFO - Buffered messages finished
23:53:18 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | Test timed out -
23:53:18 INFO - GECKO(817) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn2.child1/context18' can't be sent as the connection is closed."
23:53:18 INFO - Removing tab.
23:53:18 INFO - Waiting for event: 'TabClose' on [object XULElement].
23:53:18 INFO - Got event: 'TabClose' on [object XULElement].
23:53:18 INFO - Tab removed and finished closing
23:53:18 INFO - GECKO(817) | MEMORY STAT | vsize 5396MB | residentFast 407MB | heapAllocated 124MB
23:53:18 INFO - TEST-OK | devtools/client/webreplay/mochitest/browser_dbg_rr_breakpoints-03.js | took 45347ms

so the JS errors are interesting and probably the culprit

:jlast or :bhackett, can either of you look at getting this fixed up- some merge from last Thursday caused dt-wr to be perma fail- many tests are timing out.

Flags: needinfo?(jmaher)
Flags: needinfo?(jlaster)
Flags: needinfo?(bhackett1024)

Thank you Joel!

Whiteboard: [stockwell needswork:owner]

I think the merge exposed a bug introduced by bug 1547084, due to different timing and whatnot. I'll try to get a fix in the next day or two.

Flags: needinfo?(bhackett1024)

Brian can this be landed?

Flags: needinfo?(bhackett1024)
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/292f7a045dac
Fix some control logic bugs, r=loganfsmyth.

Sorry for the delay, I've been away from internet the last couple days.

Flags: needinfo?(bhackett1024)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee: nobody → bhackett1024
Flags: needinfo?(jlaster)

Is this something we should consider for Beta backport? Please nominate it for approval if so.

Flags: needinfo?(bhackett1024)
Keywords: regression

No, web replay is nightly only.

Flags: needinfo?(bhackett1024)
You need to log in before you can comment on or make changes to this bug.