Closed Bug 1483365 Opened Last year Closed Last year

Crash in mozilla::recordreplay::RR_mach_msg

Categories

(Core :: Web Replay, defect, critical)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: calixte, Assigned: bhackett)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-37f39820-7564-4cf0-bcef-be5830180814.
=============================================================

Top 10 frames of crashing thread:

0  @0x7fff7752920a 
1 XUL mozilla::recordreplay::RR_mach_msg toolkit/recordreplay/ProcessRedirect.h:119
2 XUL google_breakpad::ReceivePort::WaitForMessage toolkit/crashreporter/google-breakpad/src/common/mac/MachIPC.mm:249
3 XUL google_breakpad::CrashGenerationClient::RequestDumpForException toolkit/crashreporter/breakpad-client/mac/crash_generation/crash_generation_client.cc:77
4 XUL google_breakpad::ExceptionHandler::WriteMinidumpWithException toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:382
5 XUL google_breakpad::ExceptionHandler::WriteForwardedExceptionMinidump toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:651
6 XUL mozilla::recordreplay::child::ReportFatalError toolkit/recordreplay/ipc/ChildIPC.cpp:315
7 XUL RecordReplayInterface_InternalRecordReplayAssert toolkit/recordreplay/ProcessRecordReplay.cpp:474
8 XUL mozilla::recordreplay::RecordReplayAssert mfbt/RecordReplay.h:474
9 XUL mozilla::recordreplay::RR_mach_absolute_time toolkit/recordreplay/ProcessRedirect.h:193

=============================================================

There are 6 crashes (from 1 installation) in nightly 63 with buildid 20180814100100. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1481009.

[1] https://hg.mozilla.org/mozilla-central/rev?node=5b2072d947e6
Flags: needinfo?(bhackett1024)
Bug 1481009 enables the crash reporter in recording/replaying processes, and from the stack it looks like everything there is working properly and this crash is for a problem in a replaying process (which previously would not have been reported at all).

Do you know if it's possible to see the .extra file from the minidump associated with these crashes?  There should be a RecordReplayError entry there but it is not in the Metadata page of the crash report.
Attached patch patchSplinter Review
I've been getting this crash locally as well.  It looks like a regression from bug 1397297 --- SliceBudget behaves non-deterministically when recording/replaying, so the SnowWhiteKiller behaves non-deterministically as a result.  This patch ignores the slice budget when recording/replaying.
Assignee: nobody → bhackett1024
Flags: needinfo?(bhackett1024)
Attachment #9002526 - Flags: review?(continuation)
Attachment #9002526 - Flags: review?(continuation) → review+
Pushed by bhackett@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3d462cf06ef0
Run SnowWhiteKiller non-incrementally when recording/replaying, r=mccr8.
https://hg.mozilla.org/mozilla-central/rev/3d462cf06ef0
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
See Also: → 1485832
Duplicate of this bug: 1485120
You need to log in before you can comment on or make changes to this bug.