Form fields shouldn't be marked invalid immediately for an add form, only an edit form

VERIFIED FIXED in Firefox 63

Status

()

P1
normal
VERIFIED FIXED
7 months ago
7 months ago

People

(Reporter: MattN, Assigned: MattN)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 verified)

Details

(Whiteboard: [webpayments-reserve])

Attachments

(1 attachment)

Flags: qe-verify+
QA Contact: hani.yacoub
Whiteboard: [webpayments]
Whiteboard: [webpayments] → [webpayments-reserve]
When editing an existing record, invalid fields should be indicated on load.

MozReview-Commit-ID: CbrqEyCUoyC
Comment on attachment 9000163 [details]
Bug 1483425 - Don't mark form fields as invalid/dirty on load in an 'add' form. r=jaws

Sam Foster [:sfoster] has approved the revision.
Attachment #9000163 - Flags: review+

Comment 3

7 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/457c223707df
Don't mark form fields as invalid/dirty on load in an 'add' form. r=sfoster

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/457c223707df
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63

Comment 5

7 months ago
Verified - Fixed on all OS.
The form fields are no longer marked as invalid immediately after opening the Add screens.
Status: RESOLVED → VERIFIED
status-firefox63: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.