Closed Bug 1483538 Opened 2 years ago Closed 1 year ago

svg anti-aliasing in inline images

Categories

(Core :: ImageLib, defect)

61 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1534188

People

(Reporter: bugzilla, Unassigned)

References

()

Details

Attachments

(2 files)

Attached image render-compare.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704192850

Steps to reproduce:

Hi,
i cant modify the image-rendering technique of an inline PNG image inside an SVG.

The Inline IMG's (downsized to 50%) are way to sharp. 

Can i somehow fix that?

Chrome/Firefox comparison in the Attachment.


Im on:
OS: Ubuntu 18.04 bionic
WM: i3
CPU: Intel Core i5-3210M @ 4x 3.1GHz
GPU: intel
Product: Firefox → Core
See Also: → 1453717
Do you have a test-case (HTML/zip file) you could attach to the bug?
Flags: needinfo?(bugzilla)
Attached image example.svg
Flags: needinfo?(bugzilla)
Thanks. I suspect this is imagelib... Though maybe SVG, feel free to change the component if I got it wrong.
Component: Untriaged → ImageLib

I believe I fixed this as part of bug 1534188. Chrome uses high quality downscaling for images embedded in an SVG, but we were not.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1534188
You need to log in before you can comment on or make changes to this bug.