Closed Bug 1483547 Opened 3 years ago Closed 3 years ago

test262/intl402/RelativeTimeFormat/prototype/format/pl-pl-style-short.js fails

Categories

(Core :: JavaScript: Internationalization API, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: jorendorff, Assigned: jorendorff)

Details

Attachments

(1 file)

The other pl-pl-*.js test failures seem to be bug 1483545, but this is different.

    ## test262/intl402/RelativeTimeFormat/prototype/format/pl-pl-style-short.js: rc = 3, run time = 0.172779
    uncaught exception: Test262Error: Expected SameValue(«za 1 000 sek.», «za 1 000 s») to be true
    REGRESSION - test262/intl402/RelativeTimeFormat/prototype/format/pl-pl-style-short.js

I don't know if the output is really wrong or what, but I'm disabling the test for now.
To clarify: It's not actually a regression -- the test is newly imported.
This seems like an error in the test.

"sek." is short, 's" is narrow. The tests tests for `short` but uses `s`...


Ms2ger - is there a reason?
Flags: needinfo?(Ms2ger)
I'm guessing the reason is that I wasn't fully awake when writing those tests. Fixed in <https://github.com/tc39/test262/pull/1681>. The remaining failures are bug 1483545 and bug 1473588.
Flags: needinfo?(Ms2ger)
(In reply to :Ms2ger (he/him; ⌚ UTC+1/+2) from comment #3)
> I'm guessing the reason is that I wasn't fully awake when writing those
> tests.

Go to sleep.  :-)
The test issue was fixed upstream and imported in bug 1484728; can we enable it yet?
Flags: needinfo?(jorendorff)
No; now it fails because of bug 1483545.

I should update the comments in jstests.list though.
Assignee: nobody → jorendorff
Flags: needinfo?(jorendorff)
Priority: -- → P3
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b5cd2090c0d2
Adjust comments in jstests.list now that pl-pl-style-short.js fails for the same reason as its fellows. r=jwalden
https://hg.mozilla.org/mozilla-central/rev/b5cd2090c0d2
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.