Closed Bug 1483616 Opened Last year Closed Last year

GeckoProfiler doesn't hook up Angle symbols

Categories

(WebExtensions :: General, defect)

x86_64
Windows 10
defect
Not set

Tracking

(firefox63 wontfix, firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: kvark, Assigned: mstange)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached file libGLESv2.zip
When a profile is taken from the windows machine, symbols for `libGLESv2.dll` are not resolved.
Whiteboard: [gfx-noted]
This is probably bug 1478419. There are lines with " m " in that .sym file.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1478419
Well, it was caused by the same change, but bug 1478419 is about Talos being broken, whereas this one is about the WebExtension APi.
Assignee: nobody → mstange
Status: RESOLVED → REOPENED
Component: Gecko Profiler → General
Product: Core → WebExtensions
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
I've filed bug 1493063 about improving the error reporting for bugs like these.
Comment on attachment 9010832 [details]
Bug 1483616 - Ignore optional m specifier in PUBLIC and FUNC lines. r?kmag

Kris Maglione [:kmag] has approved the revision.
Attachment #9010832 - Flags: review+
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/efcd26d12ba6
Ignore optional m specifier in PUBLIC and FUNC lines. r=kmag
https://hg.mozilla.org/mozilla-central/rev/efcd26d12ba6
Status: ASSIGNED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Will manual testing be required on this fix? if so please provide some steps to help validate, otherwise set the 'qe-validate-' flag, thanks
Flags: needinfo?(mstange)
This is not a user facing change so it doesn't need validation. It only improves developer workflows.
Flags: needinfo?(mstange) → qe-verify-
You need to log in before you can comment on or make changes to this bug.