Closed Bug 1483641 Opened Last year Closed Last year

Testpilot shutdown crashes

Categories

(Firefox :: General, defect)

63 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox61 --- wontfix
firefox62 --- affected
firefox63 --- affected

People

(Reporter: lizzard, Unassigned)

References

(Blocks 1 open bug)

Details

Crash Data

In bug 1464938 we're tracking various shutdown hangs/crashes associated with addons, and the overall volume is very high on release and beta. By digging into some of the specific addons we are hoping to reduce the crash volume some more. These crash signatures are from frozen content processes from Testpilot.
Will, can you take a look?
Flags: needinfo?(wclouser)
Blocks: 1464938
I looked through a dozen crash reports[1] and all of them were using very old versions of the test pilot add-on.  Some as late as May (still months ago), but many from last November.  During that time period the Test Pilot add-on converted from being a bootstrap add-on to being a web extension, so, it's not a surprise the old add-ons are failing (although I'd rather they didn't crash, of course).  The answer here is for users to upgrade to newer versions of the Test Pilot add-on.  Outside of blocking the old add-on versions, I'm not sure there is much we can do here.


[1] Is there a way to query crash-stats to group by Test Pilot add-on version?
Flags: needinfo?(wclouser)
An analysis from jhirsch:

> @clouserw OK, here's my theory: the addons team changed embedded webextension startup a couple months ago, from we.startup(reason) to we.startup(reason, addonData). You may recall they refactored Screenshots startup for us: https://hg.mozilla.org/releases/mozilla-beta/rev/4a309778103f
> But looking at the test pilot addon as of version 2.0.6-dev-d957066, the embedded startup is using the old way https://github.com/mozilla/testpilot/blob/d95706613444e96ab75ce12d723e19482d6d28df/addon/src/lib/webExtension.js#L31
> 
>   const { browser } = await webExtension.startup(reason);
> 
> So, I'm guessing the actual root here is either this, or some other refactoring in the webextension startup code that's broken on these ancient test pilot builds 
> I guess the issue in the crash is a shutdown hang, which we saw with screenshots not shutting down properly in automated testing for a while

So, I'm going to cautiously close this as we're already offering newer/fixed versions of the add-on to clients that will accept upgrades.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
What was the issue with screenshots not shutting down properly?
Flags: needinfo?(wclouser)
Flags: needinfo?(wclouser) → needinfo?(jhirsch)
I am one of those that is (now was) suffering from the hang and crash on Firefox shutdown. Unfortunately, the solution of updating Test Pilot is not as simple as it sounds: the installation of the updated version of Test Pilot also hangs (presumably for the same reason).

However, there is a simple workaround. Disable Test Pilot, restart Firefox (waiting for the hang and crash), and then update and re-enable Test Pilot.
> What was the issue with screenshots not shutting down properly?

Check out bug 1373614. That's one of a small class of (typically sort of artificial) crashes caused by tests rapidly starting and shutting down Firefox, before Screenshots has a chance to fully load.
Flags: needinfo?(jhirsch)
> I am one of those that is (now was) suffering from the hang and crash on Firefox shutdown. Unfortunately, the solution of updating Test Pilot is not as simple as it sounds: the installation of the updated version of Test Pilot also hangs (presumably for the same reason).
> However, there is a simple workaround. Disable Test Pilot, restart Firefox (waiting for the hang and crash), and then update and re-enable Test Pilot.

I'm sorry that you had to resort to such a complicated set of steps to fix the bug!

When you encountered this bug, were you using a Firefox profile that had not been used for a long time (months or more)?
Flags: needinfo?(mozilla-bugzilla)
We should probably consider doing a soft block or a compat override for older test pilot versions. Otherwise, people having this issue won't get automatic updates at all, and won't be able to manually update without effort.
(In reply to Jared Hirsch [:_6a68] [:jhirsch] from comment #7)
> I'm sorry that you had to resort to such a complicated set of steps to fix
> the bug!
> 
> When you encountered this bug, were you using a Firefox profile that had not
> been used for a long time (months or more)?

In that case, no, it was a profile without automatic extension updates turned on as hypothesised.
Flags: needinfo?(mozilla-bugzilla)
(In reply to Kris Maglione [:kmag] from comment #8)
> We should probably consider doing a soft block or a compat override for
> older test pilot versions. Otherwise, people having this issue won't get
> automatic updates at all, and won't be able to manually update without
> effort.

I filed https://bugzilla.mozilla.org/show_bug.cgi?id=1485083
You need to log in before you can comment on or make changes to this bug.