Intermittent browser_ext_browserAction_popup_resize.js | Window height should increase (Y >= X) -

RESOLVED FIXED in Firefox 66

Status

defect
P5
normal
RESOLVED FIXED
11 months ago
4 months ago

People

(Reporter: intermittent-bug-filer, Assigned: rpl)

Tracking

(Blocks 1 bug, {intermittent-failure})

unspecified
mozilla67
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox65 wontfix, firefox66 fixed, firefox67 fixed)

Details

(Whiteboard: [stockwell fixed])

Attachments

(2 attachments)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=194163535&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/BofISAukScuZxRoP-114wA/runs/0/artifacts/public/logs/live_backing.log

14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should increase (432 > 176) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
14:03:05     INFO - Buffered messages finished
14:03:05     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (432 >= 628) - 
14:03:05     INFO - Stack trace:
14:03:05     INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js:testPopupSize:222
14:03:05     INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js:testBrowserActionMenuResizeQuirks:283
14:03:05     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
14:03:05     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
14:03:05     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:999
14:03:05     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Document should not be vertically scrollable - 0 <= 1 - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | 61 - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (544 >= 149) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Bottom of popup should be on-screen. (567 <= 1120) - 
14:03:05     INFO - Increase body children's width and height. Expect them to wrap, and the frame to grow vertically rather than widen.
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should increase (335 > 176) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
14:03:05     INFO - Not taking screenshot here: see the one that was previously logged
14:03:05     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (335 >= 628) - 
14:03:05     INFO - Stack trace:
14:03:05     INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js:testPopupSize:237
14:03:05     INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js:testBrowserActionMenuResizeQuirks:283
14:03:05     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
14:03:05     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
14:03:05     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:999
14:03:05     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Document should not be vertically scrollable - 0 <= 1 - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | 61 - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (447 >= 149) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Bottom of popup should be on-screen. (470 <= 1120) - 
14:03:05     INFO - Increase body height beyond the height of the screen. Expect the panel to grow to accommodate, but not larger than the height of the screen.
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should increase (1025 > 176) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (1025 > 628) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Document should be vertically scrollable (1401 > 0) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | 61 - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (1082 >= 149) - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Bottom of popup should be on-screen. (1105 <= 1120) - 
14:03:05     INFO - Restore original styling. Expect original dimensions.
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should return to its original value - 
14:03:05     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
14:03:05     INFO - Not taking screenshot here: see the one that was previously logged
14:03:05     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should return to its original value - Got 176, expected 628
Duplicate of this bug: 1483706
There have been 33 failures within the last 7 days:
- 3 failures on windows 7x32 debug
- 12 failures on windows 10x64 debug
- 11 failures on OS X 10.10 debug
- 3 failures on linux x64 debug
- 4 failures on linux x32 debug

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=195110342&repo=mozilla-inbound&lineNumber=18120

17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should increase (446 > 174) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (645 >= 634) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Document should not be vertically scrollable - 0 <= 1 - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | 50 - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (-650 <= -42) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Top of popup should be on-screen. (294 >= 0) - 
17:42:01     INFO - Increase body children's width and height. Expect them to wrap, and the frame to grow vertically rather than widen.
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should increase (331 > 174) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
17:42:01     INFO - Buffered messages finished
17:42:01     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (331 >= 634) - 
17:42:01     INFO - Stack trace:
17:42:01     INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js:testPopupSize:237
17:42:01     INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js:testBrowserActionMenuResizeBottomArrow:315
17:42:01     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1106
17:42:01     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
17:42:01     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:999
17:42:01     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Document should not be vertically scrollable - 0 <= 1 - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | 50 - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (-336 <= -42) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Top of popup should be on-screen. (608 >= 0) - 
17:42:01     INFO - Increase body height beyond the height of the screen. Expect the panel to grow to accommodate, but not larger than the height of the screen.
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should increase (979 > 174) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (979 > 634) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Document should be vertically scrollable (1093 > 0) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | 50 - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (-933 <= -42) - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Top of popup should be on-screen. (11 >= 0) - 
17:42:01     INFO - Restore original styling. Expect original dimensions.
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Browser height should return to its original value - 
17:42:01     INFO - TEST-PASS | browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window width should not change - 
17:42:01     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(ddurst)
Whiteboard: [stockwell needswork:owner]
Summary: Intermittent browser/components/extensions/test/browser/test-oop-extensions/browser_ext_browserAction_popup_resize.js | Window height should increase (Y >= X) - → Intermittent browser_ext_browserAction_popup_resize.js | Window height should increase (Y >= X) -
Duplicate of this bug: 1488153
Flags: needinfo?(ddurst)
Disabled browser_ext_browserAction_popup_resize.js on mac, linux and windows, debug and verify
Attachment #9033139 - Flags: review?(jmaher)
:ddurst Hi, there are 89 failures in the past 30 days and the bug is unassigned. Unless there is no other solution to be proposed for this bug, i have disabled the test just in case you consider it is needed.
Flags: needinfo?(ddurst)
Attachment #9033139 - Flags: review?(jmaher) → review+
Whiteboard: [stockwell unknown] → [stockwell disabled]
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8b2a9ba0dda5
Disable browser_ext_browserAction_popup_resize.js on Windows, Linux and Mac, debug and verify. r=jmaher
Keywords: checkin-needed
See Also: → 1480292
See Also: → 1446274

This patch applies the following changes:

  • Reduce the chances of retrieving the initial popup panel size while it is resizing, by comparing the
    content dimensions retrieved before and after the delay (which is already set to a value comparable
    to the time used by the resize debouncing timer), and wait until both the dimensions collected are the same

  • split browser_ext_browserAction_popup_resize.js into two test files (as it seems, based on the investigations
    I did by reproducing this intermittent locally, that the part that can still fail intermittently from time
    to time with the change describe above is related to the testBrowserActionMenuResizeBottomArrow test case)

  • move the test helpers shared between the two test files into a new head_browserAction.js support file

  • re-enabled browser_ext_browserAction_popup_resize.js

  • mark the new browser_ext_browserAction_popup_resize_bottom.js as disabled on debug build,
    because it is consistently triggering a "shutdown leak" failure when running locally

Push to try of the changes applied in the attached patch (running test-verify-e10s for 5 times, to double-check that the intermittent failures are not being triggered with the above changes applied):

Blocks: 1522164
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/5852bd6e33d2
Split and re-enable browser_ext_browserAction_popup_resize.js. r=mixedpuppy

Backed out changeset 5852bd6e33d2 (Bug 1483701) for bc failures in browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js CLOSED TREE

https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&selectedJob=223850961&revision=5852bd6e33d2dd79007c86fba5ac7a10df6e72b9

https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&selectedJob=223840216

https://treeherder.mozilla.org/logviewer.html#?job_id=223840216&repo=autoland

[task 2019-01-24T19:42:01.376Z] 19:42:01 INFO - Buffered messages finished
[task 2019-01-24T19:42:01.377Z] 19:42:01 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel has not moved downwards - Got 61, expected 0
[task 2019-01-24T19:42:01.378Z] 19:42:01 INFO - Stack trace:
[task 2019-01-24T19:42:01.380Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:test_is:1318
[task 2019-01-24T19:42:01.381Z] 19:42:01 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/head_browserAction.js:checkPanelPosition:116
[task 2019-01-24T19:42:01.382Z] 19:42:01 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/head_browserAction.js:testPopupSize:174
[task 2019-01-24T19:42:01.383Z] 19:42:01 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js:testBrowserActionMenuResizeQuirks:74
[task 2019-01-24T19:42:01.384Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1108
[task 2019-01-24T19:42:01.385Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1099
[task 2019-01-24T19:42:01.386Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:997
[task 2019-01-24T19:42:01.387Z] 19:42:01 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-01-24T19:42:01.388Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (548 >= 92) -
[task 2019-01-24T19:42:01.389Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Bottom of popup should be on-screen. (548 <= 1200) -
[task 2019-01-24T19:42:01.390Z] 19:42:01 INFO - Increase body children's width and height. Expect them to wrap, and the frame to grow vertically rather than widen.
[task 2019-01-24T19:42:01.391Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Browser height should increase (332 > 174) -
[task 2019-01-24T19:42:01.392Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window width should not change -
[task 2019-01-24T19:42:01.393Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window height should increase (332 >= 174) -
[task 2019-01-24T19:42:01.394Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Document should not be vertically scrollable - 0 <= 1 -
[task 2019-01-24T19:42:01.395Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected -
[task 2019-01-24T19:42:01.396Z] 19:42:01 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-01-24T19:42:01.397Z] 19:42:01 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel has not moved downwards - Got 61, expected 0
[task 2019-01-24T19:42:01.398Z] 19:42:01 INFO - Stack trace:
[task 2019-01-24T19:42:01.398Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:test_is:1318
[task 2019-01-24T19:42:01.399Z] 19:42:01 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/head_browserAction.js:checkPanelPosition:116
[task 2019-01-24T19:42:01.400Z] 19:42:01 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/head_browserAction.js:testPopupSize:189
[task 2019-01-24T19:42:01.400Z] 19:42:01 INFO - chrome://mochitests/content/browser/browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js:testBrowserActionMenuResizeQuirks:74
[task 2019-01-24T19:42:01.401Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1108
[task 2019-01-24T19:42:01.402Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1099
[task 2019-01-24T19:42:01.403Z] 19:42:01 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:997
[task 2019-01-24T19:42:01.403Z] 19:42:01 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-01-24T19:42:01.404Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel has not shrunk from original size (448 >= 92) -
[task 2019-01-24T19:42:01.405Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Bottom of popup should be on-screen. (448 <= 1200) -
[task 2019-01-24T19:42:01.406Z] 19:42:01 INFO - Increase body height beyond the height of the screen. Expect the panel to grow to accommodate, but not larger than the height of the screen.
[task 2019-01-24T19:42:01.407Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Browser height should increase (1124 > 174) -
[task 2019-01-24T19:42:01.410Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window width should not change -
[task 2019-01-24T19:42:01.411Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window height should increase (1124 > 174) -
[task 2019-01-24T19:42:01.412Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Document should be vertically scrollable (1300 > 0) -
[task 2019-01-24T19:42:01.413Z] 19:42:01 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel arrow is positioned as expected -
[task 2019-01-24T19:42:01.414Z] 19:42:01 INFO - Not taking screenshot here: see the one that was previously logged

Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b918623055e
Backed out changeset 5852bd6e33d2 for bc failures in browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js CLOSED TREE
Duplicate of this bug: 1522636

I looked into the failures mentioned in comment 34, they are new failures and it looks to be related to the recently introduced changes applied to PanelMultiView.jsm autopositioning from Bug 1520607, we didn't noticed it when Bug 1520607 has been landed (a couple of days ago) because browser_ext_browserAction_popup_resize.js is currently disabled on all the platforms, and the last try pushes I've been double-checking didn't included Bug 1520607 changes yet.

Bug 1522636 is also about the new failures triggered by Bug 1520607 on browser_ext_browserAction_popup_resize.js, and so I marked it as a duplicate of this bugzilla issue (as the failure is the same that is mentioned in comment 64 and backed out by the patch linked in comment 35).

I'm re-opening the phabricator revision to apply the additional changes to fix these new failures.

Flags: needinfo?(ddurst)

The try push of the updated patch is not completed and it looks green again:

I'm going to push to autoland the updated patch.

Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/49b9a79baf65
Split and re-enable browser_ext_browserAction_popup_resize.js. r=mixedpuppy

Backed out changeset 49b9a79baf65 (bug 1483701) for brwoser-chrome failures in browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js. CLOSED TREE

Log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=224098369&repo=autoland&lineNumber=2174

INFO - TEST-START | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js
[task 2019-01-25T21:04:32.015Z] 21:04:32 INFO - TEST-INFO | started process screentopng
[task 2019-01-25T21:04:32.446Z] 21:04:32 INFO - TEST-INFO | screentopng: exit 0
[task 2019-01-25T21:04:32.446Z] 21:04:32 INFO - Buffered messages logged at 21:04:25
[task 2019-01-25T21:04:32.448Z] 21:04:32 INFO - Entering test bound testSetup
[task 2019-01-25T21:04:32.449Z] 21:04:32 INFO - Leaving test bound testSetup
[task 2019-01-25T21:04:32.450Z] 21:04:32 INFO - Entering test bound testBrowserActionPopupResize
[task 2019-01-25T21:04:32.452Z] 21:04:32 INFO - Extension loaded
[task 2019-01-25T21:04:32.454Z] 21:04:32 INFO - Buffered messages logged at 21:04:26
[task 2019-01-25T21:04:32.456Z] 21:04:32 INFO - Console message: Warning: attempting to write 4262 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:04:32.456Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Expect widget not to be overflowed -
[task 2019-01-25T21:04:32.457Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel window should be 200px tall (was 200) - 0 <= 1 -
[task 2019-01-25T21:04:32.458Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel body should be tall enough to fit its contents -
[task 2019-01-25T21:04:32.459Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel window should be 200px wide - 0 <= 1 -
[task 2019-01-25T21:04:32.459Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel body should be wide enough to fit its contents -
[task 2019-01-25T21:04:32.462Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel window should be 400px tall (was 400) - 0 <= 1 -
[task 2019-01-25T21:04:32.464Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel body should be tall enough to fit its contents -
[task 2019-01-25T21:04:32.466Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel window should be 400px wide - 0 <= 1 -
[task 2019-01-25T21:04:32.467Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel body should be wide enough to fit its contents -
[task 2019-01-25T21:04:32.469Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel window should be 300px tall (was 300) - 0 <= 1 -
[task 2019-01-25T21:04:32.470Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel body should be tall enough to fit its contents -
[task 2019-01-25T21:04:32.471Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel window should be 300px wide - 0 <= 1 -
[task 2019-01-25T21:04:32.472Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Panel body should be wide enough to fit its contents -
[task 2019-01-25T21:04:32.473Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | browserAction popup has been closed -
[task 2019-01-25T21:04:32.474Z] 21:04:32 INFO - Leaving test bound testBrowserActionPopupResize
[task 2019-01-25T21:04:32.476Z] 21:04:32 INFO - Entering test bound testBrowserActionMenuResizeStandards
[task 2019-01-25T21:04:32.477Z] 21:04:32 INFO - Extension loaded
[task 2019-01-25T21:04:32.478Z] 21:04:32 INFO - Console message: Warning: attempting to write 4374 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:04:32.479Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Expect widget not to be overflowed -
[task 2019-01-25T21:04:32.480Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Document has the expected compat mode -
[task 2019-01-25T21:04:32.481Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window height should not change -
[task 2019-01-25T21:04:32.482Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window width should increase (647 > 87) -
[task 2019-01-25T21:04:32.483Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window height should not change -
[task 2019-01-25T21:04:32.483Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window width should return to approximately its original value (87 ~= 87) -
[task 2019-01-25T21:04:32.484Z] 21:04:32 INFO - Console message: Warning: attempting to write 4318 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:04:32.485Z] 21:04:32 INFO - Console message: Warning: attempting to write 4374 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:04:32.486Z] 21:04:32 INFO - Buffered messages finished
[task 2019-01-25T21:04:32.486Z] 21:04:32 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Uncaught exception - Wait the popup opening to be completed - timed out after 50 tries.
[task 2019-01-25T21:04:32.487Z] 21:04:32 INFO - Leaving test bound testBrowserActionMenuResizeStandards
[task 2019-01-25T21:04:32.488Z] 21:04:32 INFO - Entering test bound testBrowserActionMenuResizeQuirks
[task 2019-01-25T21:04:32.488Z] 21:04:32 INFO - Extension loaded
[task 2019-01-25T21:04:32.489Z] 21:04:32 INFO - Console message: Warning: attempting to write 4486 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:04:32.490Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Expect widget not to be overflowed -
[task 2019-01-25T21:04:32.491Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Document has the expected compat mode -
[task 2019-01-25T21:04:32.492Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window height should not change -
[task 2019-01-25T21:04:32.493Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window width should increase (647 > 87) -
[task 2019-01-25T21:04:32.493Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window height should not change -
[task 2019-01-25T21:04:32.494Z] 21:04:32 INFO - TEST-PASS | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Window width should return to approximately its original value (87 ~= 87) -
[task 2019-01-25T21:04:32.495Z] 21:04:32 INFO - Console message: Warning: attempting to write 4430 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:04:32.496Z] 21:04:32 INFO - Console message: Warning: attempting to write 4486 bytes to preference browser.uiCustomization.state. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
[task 2019-01-25T21:05:10.953Z] 21:05:10 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-01-25T21:05:10.956Z] 21:05:10 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Test timed out -
[task 2019-01-25T21:05:10.958Z] 21:05:10 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-01-25T21:05:10.959Z] 21:05:10 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Extension left running at test shutdown -
[task 2019-01-25T21:05:10.959Z] 21:05:10 INFO - Stack trace:
[task 2019-01-25T21:05:10.960Z] 21:05:10 INFO - chrome://mochikit/content/browser-test.js:test_ok:1307
[task 2019-01-25T21:05:10.961Z] 21:05:10 INFO - chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:ExtensionTestUtils.loadExtension/<:109
[task 2019-01-25T21:05:10.962Z] 21:05:10 INFO - chrome://mochikit/content/browser-test.js:nextTest:707
[task 2019-01-25T21:05:10.963Z] 21:05:10 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1205
[task 2019-01-25T21:05:10.964Z] 21:05:10 INFO - setTimeout handlerchrome://mochikit/content/browser-test.js:Tester_execTest:1167
[task 2019-01-25T21:05:10.965Z] 21:05:10 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:997
[task 2019-01-25T21:05:10.966Z] 21:05:10 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-01-25T21:05:11.000Z] 21:05:11 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-01-25T21:05:11.002Z] 21:05:11 INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | Extension left running at test shutdown -
[task 2019-01-25T21:05:11.005Z] 21:05:11 INFO - Stack trace:
[task 2019-01-25T21:05:11.006Z] 21:05:11 INFO - chrome://mochikit/content/browser-test.js:test_ok:1307
[task 2019-01-25T21:05:11.007Z] 21:05:11 INFO - chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:ExtensionTestUtils.loadExtension/<:109
[task 2019-01-25T21:05:11.009Z] 21:05:11 INFO - chrome://mochikit/content/browser-test.js:nextTest:707
[task 2019-01-25T21:05:11.010Z] 21:05:11 INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1205
[task 2019-01-25T21:05:11.011Z] 21:05:11 INFO - setTimeout handler
chrome://mochikit/content/browser-test.js:Tester_execTest:1167
[task 2019-01-25T21:05:11.013Z] 21:05:11 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:997
[task 2019-01-25T21:05:11.014Z] 21:05:11 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-01-25T21:05:11.045Z] 21:05:11 INFO - GECKO(2283) | MEMORY STAT | vsize 690MB | residentFast 279MB | heapAllocated 75MB
[task 2019-01-25T21:05:11.047Z] 21:05:11 INFO - TEST-OK | browser/components/extensions/test/browser/browser_ext_browserAction_popup_resize.js | took 45101ms

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=224063127&revision=49b9a79baf65069fea7b91d3498571eac30d28d5

Backout:
https://hg.mozilla.org/integration/autoland/rev/f0e2ba567625f319225324410315ed9bd07ce1f4

Flags: needinfo?(lgreco)

I've been looking into reproducing this timeout locally, but I'm unable to reproduce it locally on any of the artifact builds, based on it seems to fail because of the initial popup position stays at top 0 in some of the builds (in particular linux32 opt and linux64 pgo, which unfortunately I didn't included in my push to try).

Nevertheless I've been able to reproduce them consistently in new try pushes which are specifically running the tasks that triggered the last backout ("test-linux32/opt-mochitest-browser-chrome-e10s-2", "test-linux64-pgo/opt-mochitest-browser-chrome-e10s-2"), and some additional logging added in a try push confirms that when the test is timing out the popup stays at top === 0 (e.g. these are some of the failure logs collected on a build with increased logging around the BrowserTestUtils.waitForCondition that is trigering the timeout: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=224173660&repo=try&lineNumber=2269).

To prevent this timeout failure, I'm changing that new BrowserTestUtils.waitForCondition to wait until the popup's "top" has the same value for at least N times in a row (so that the test is sure enough that the value we are retrieving is stable and we can expect that the resized popups should still be in the same position, and we don't assume anymore that it is going to be a value != 0, as the failures show that it is not a right assumption).

Last try pushes seem to also confirm that this should prevent this timeout failure:

Flags: needinfo?(lgreco)
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/b1d153e12d49
Split and re-enable browser_ext_browserAction_popup_resize.js. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Keywords: leave-open
Resolution: --- → FIXED
Whiteboard: [stockwell disabled] → [stockwell fixed]
Target Milestone: --- → mozilla67

From my understanding this issue is related to the addon tests. Is there any need of manual QA here? If not can you please mark it as "qe-verify- "

Flags: needinfo?(lgreco)
Flags: needinfo?(lgreco) → qe-verify-
You need to log in before you can comment on or make changes to this bug.