Closed Bug 1483788 Opened Last year Closed Last year

Intermittent dom/payments/test/browser_payment_in_different_tabs.js | 0 - details.displayItems should be a zero length array.

Categories

(Core :: DOM: Web Payments, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1480872

People

(Reporter: intermittent-bug-filer, Assigned: marcosc)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Assignee: nobody → mcaceres
Priority: P5 → P2
I've simplified the test a bit... might help... can reproduce locally, unfortunately.
Attachment #9001555 - Flags: review?(echuang)
Attachment #9001555 - Flags: review?(echuang) → review+
Marcos, make sure you update your code base and no conflict when applying patches before you set the check-in-needed.

Basically, I give r+ with the idea of modifications on simple_payment_request.html, but I think it is out of date.
Flags: needinfo?(mcaceres)
Thanks for the reminder. I’ll rebase.
Flags: needinfo?(mcaceres)
Attached patch RefactorSplinter Review
Ok, I think this is closer to what we want here. We can now spin up as many tabs as a we want (instead of just 2). The test should be much less racy now 🤞.

simple_payment_request.html was also a bit racy... I now get it to `await responsePromise;`, can try to gracefully handle potential rejections. 

I think trying to use `window.parent.postMessage` should just throw if the parent is missing. Otherwise, we will end up with silent fails/bugs. 

If we `simple_payment_request.html` to be used as a top level document, we should make a new test file for that. 

re-requesting review, as I've rewritten basically everything from yesterday.
Attachment #9001555 - Attachment is obsolete: true
Attachment #9001848 - Flags: review?(echuang)
Set this bug as a duplicate bug of bug 1480872.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1480872
Comment on attachment 9001848 [details] [diff] [review]
Refactor

Review of attachment 9001848 [details] [diff] [review]:
-----------------------------------------------------------------

Move the review to bug 1480872
Attachment #9001848 - Flags: review?(echuang) → review-
You need to log in before you can comment on or make changes to this bug.