Closed Bug 1483825 Opened Last year Closed Last year

Have consistent pref for ShadowDOM between unittests and nightly

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1471947

People

(Reporter: edgar, Assigned: edgar)

Details

We disable shadowDOM while running tests [1] which is because of bug 1398981 (we use the same pref for CustomElement and ShadowDom at that time and the ShadowDom isn't ready). But right now ShadowDOM has already enabled on nightly by default, it seems not necessary to have inconsistent configuration between testing and nightly for ShadowDOM.

And this will also make the result of https://staging.wpt.fyi/results/shadow-dom?product=firefox[experimental] more accurate (which use the pref under testing/profiles [2]).

[1] https://searchfox.org/mozilla-central/rev/5dbfd833bbb114afe758db4d4bdbc5b13bcc33ef/testing/profiles/unittest/user.js#121
[2] https://github.com/web-platform-tests/wpt.fyi/blob/8c0e0c131f99f096b4c53e8196fbe750ca3f819c/webapp/components/test-run.html#L151-L153
Assignee: nobody → echen
I'm changing the testing pref to true.
That makes couple of tests UNEXPECTED_PASS and some tests, expectedly fail.
Priority: -- → P3
I guess this is now a dup of bug 1471947
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1471947
though, we may want to remove the prefs from testing profile altogether.
You need to log in before you can comment on or make changes to this bug.