Closed Bug 1483832 Opened 3 years ago Closed 11 months ago

cookie is not sent to server after 302 redirect with set-cookie header

Categories

(Core :: Networking: Cookies, defect, P2)

61 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1465402

People

(Reporter: Gtofig, Unassigned)

Details

(Whiteboard: [necko-triaged])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704194937

Steps to reproduce:

- Client makes call to domain: example.com/?param=test
- Client receives 302 redirect back to example.com with set-cookie header in response with path set to '/' and domain set to example.com and sameSite set to strict



Actual results:

- Client makes call to example.com but there is no cookie in the request, although cookie is present in cookie storage

If page is then refreshed, cookie is sent correctly on all subsequent requests.


Expected results:

Client should have sent cookie to the server

This worked correctly on Firefox 52 for me, but failed on Firefox 60 and 61.
Component: Untriaged → Networking: Cookies
Product: Firefox → Core
Please correct if this is not the right component. Thanks.
Hi Gtofig. Thanks for reporting this. Do you have a public website that we can use to test this?
Otherwise, could you help us narrow down when this behaviour was introduced by using mozregression? https://mozilla.github.io/mozregression/quickstart.html
Thanks!
Flags: needinfo?(Gtofig)
Priority: -- → P2
Whiteboard: [necko-triaged]
Hi,

We found out that a similar issue was already reported: https://bugzilla.mozilla.org/show_bug.cgi?id=1465402

It appears to be matching what we are seeing so I suspect it is the same one. However, we were not able to reliably reproduce error for some reason. I will update if we can create a minimal case for this.

Thanks
Flags: needinfo?(Gtofig)
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1465402
You need to log in before you can comment on or make changes to this bug.