Closed Bug 1483886 Opened 3 years ago Closed 3 years ago

Attachment icon and twisty are white on selected treeitems on Windows

Categories

(Thunderbird :: Theme, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 63.0

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(1 file)

This is also a fallout of bug 1469287: the attachment icon and the twisty on a selected treeitem are white instead black. This happens only on default themes.
Attached patch treeColors.patchSplinter Review
This fixes it. Mac needs no more the selected attachment icon. Set the attachment icon size is also no more needed.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9001614 - Flags: review?(jorgk)
What's a default theme on Windows 10 and how do I enable it? I'm on W10 1803.
You're on default theme. High Contrast or Classic on Win 7 are non-default themes.
Comment on attachment 9001614 [details] [diff] [review]
treeColors.patch

Another "find the problem first" review :-(

So the problem is that in the thread pane the paperclip icon is white instead of black. And in a threaded view, the twisty is also white. I can reproduce that. Richard told me via IRC.

The patch fixes that.
Attachment #9001614 - Flags: review?(jorgk) → review+
Thanks.
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ce2e22c9b8ab
Bug 1483332 follow-up: Make twisty and other tree icons use the correct selected color on Windows default themes. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
You need to log in before you can comment on or make changes to this bug.