Closed Bug 1483909 Opened Last year Closed Last year

Crash in shutdownhang | ntdll.dll@0x9d7a4

Categories

(Core :: XPCOM, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-bed11735-7bb4-4f16-883e-ddc490180816.
=============================================================

This signature is rising on both release and beta: https://bit.ly/2MnjEY0. I guessed on where to put this, not sure it belongs in the current component.

All of the users are running Windows 10 and many I looked at were 10.0.17134, which appears to be Redstone 4.

Comments:
* The crash occurred during the first time I tried opening the Firefox browser after a mandatory Windows 10 update. All other processes on the computer are painfully slow, too. 
* Got the white screen. Computer was on all day, and I was often away from desk, coming back every hour or two and having to bring it from sleep mode and re-do login. After being on for 15 hours I then got white screen. When entering a web address in the address bar, I only got the little whirling circular progress icon. 

Top 10 frames of crashing thread:

0 ntdll.dll ntdll.dll@0x9d7a4 
1 ntdll.dll ntdll.dll@0x1ef18 
2 xul.dll nsAppShell::ProcessNextNativeEvent widget/windows/nsAppShell.cpp:578
3 xul.dll mozilla::CondVar::Wait xpcom/threads/CondVar.h:66
4 xul.dll mozilla::ThreadEventQueue<mozilla::PrioritizedEventQueue<mozilla::EventQueue> >::GetEvent xpcom/threads/ThreadEventQueue.cpp:155
5 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:994
6 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:519
7 xul.dll mozilla::dom::quota::QuotaManager::ShutdownObserver::Observe dom/quota/ActorsParent.cpp:2913
8 xul.dll nsObserverList::NotifyObservers xpcom/ds/nsObserverList.cpp:112
9 xul.dll nsObserverService::NotifyObservers xpcom/ds/nsObserverService.cpp:297

=============================================================
most likely it's due to windows patch day and we don't have proper symbols yet for ntdll.dll - if we had, i suspect the signatures here fall into our usual shutdownhang candidates.
Adding another similar signature without a bug. This one seems to be all Win 7 crashes. Lots of the same types of comments and crashes started in a similar time frame to this one.
Crash Signature: [@ shutdownhang | ntdll.dll@0x9d7a4] → [@ shutdownhang | ntdll.dll@0x9d7a4] [@ shutdownhang | ntdll.dll@0x6b19a]
Depends on: 1486825
I reprocessed one crash in shutdownhang | ntdll.dll@0x6b19a and the signature translates to [@ shutdownhang | mozilla::dom::quota::QuotaManager::ShutdownObserver::Observe ] (https://crash-stats.mozilla.com/report/index/f237ad89-46d2-4881-9e5f-6323b0180829?refresh=cache#tab-bugzilla). That bug (Bug 1411908) has a recent comment about filing a new bug for the remaining crashes, which I can do shortly.

The first signature, when reprocessed is [@ shutdownhang | mozilla::SpinEventLoopUntil<T> | mozilla::dom::quota::QuotaManager::ShutdownObserver::Observe ] (https://crash-stats.mozilla.com/report/index/e8b77a57-9fb8-4c81-9f8b-7222d0180829?refresh=cache#tab-bugzilla), which also appears to be the same Bug 1411908.

I will be filing a new bug shortly to cover these two signatures.
Bug 1487194 was filed to address these 2 signatures.
Is there anything left to do here?
Flags: needinfo?(mozillamarcia.knous)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)
> Is there anything left to do here?

I think we can close this one out. I filed the bug to address the two signatures that are still occurring.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.