Closed Bug 1483939 Opened Last year Closed Last year

Pass only search string to in-content telemetry URLParams

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox62 + fixed
firefox63 + fixed

People

(Reporter: mkaply, Assigned: mkaply)

Details

Attachments

(1 file)

When passing a string to URLParams, in-content telemetry isn't removing information after a possible #.

We should.
[Tracking Requested - why for this release]: This is a simple correctness fix to our data. It's an edge case, but we don't want to accidentally collect extra data.
Comment on attachment 9001680 [details]
Bug 1483939 - Account for anchor when creating URLSearchParams.

Mike de Boer [:mikedeboer] has approved the revision.
Attachment #9001680 - Flags: review+
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/b0bad5241f20
Account for anchor when creating URLSearchParams. r=mikedeboer
https://hg.mozilla.org/mozilla-central/rev/b0bad5241f20
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 9001680 [details]
Bug 1483939 - Account for anchor when creating URLSearchParams.

Approval Request Comment
[Feature/Bug causing the regression]: Some search codes have extra text
[User impact if declined]: None.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: Non
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Just an update to our string manipulation.
[String changes made/needed]:
Attachment #9001680 - Flags: approval-mozilla-beta?
Comment on attachment 9001680 [details]
Bug 1483939 - Account for anchor when creating URLSearchParams.

Remove stuff after anchor text for telemetry, let's take this for beta 19.
Attachment #9001680 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Mike can you suggest some way to verify this?
Flags: needinfo?(mozilla)
Sure. 

Do a search on Google and notice the result URL:

https://www.google.com/search?q=test&ie=utf-8&oe=utf-8&client=firefox-b-1-ab

Go to about:telemetry. Verify there is one search count that looks like this:

google.in-content.sap:firefox-b-1-ab

Add something like this to the end of the search URL.

https://www.google.com/search?q=test&ie=utf-8&oe=utf-8&client=firefox-b-1-ab#additional_text

Go to about:telemetry and verify that there is one additional search count.

Previously you would have seen a new entry that looked like this:

google.in-content.sap:firefox-b-1-ab#additional_text
Flags: needinfo?(mozilla)
You need to log in before you can comment on or make changes to this bug.