Intermittent toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico

RESOLVED FIXED in Firefox 63

Status

defect
P5
normal
RESOLVED FIXED
Last year
7 months ago

People

(Reporter: intermittent-bug-filer, Assigned: robwu)

Tracking

({intermittent-failure})

unspecified
mozilla63
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox63 fixed)

Details

(Whiteboard: [retriggered] [stockwell fixed])

Attachments

(1 attachment)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=194402870&repo=autoland

https://queue.taskcluster.net/v1/task/Zc9et47oQou_m3zKPWASGg/runs/0/artifacts/public/logs/live_backing.log

13:38:55     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | received onCompleted 
13:38:55     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | resource type is correct - Expected: main_frame, Actual: main_frame 
13:38:55     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | origin is correct - Expected: http://mochi.test:8888/tests/toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html, Actual: http://mochi.test:8888/tests/toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html 
13:38:55     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | correct requestId - Expected: 47, Actual: 47 
13:38:55     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | correct tabId - Expected: 47, Actual: 47 
13:38:55     INFO - onBeforeRequest 48 http://mochi.test:8888/favicon.ico
13:38:55     INFO - Buffered messages finished
13:38:55     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico 
13:38:55     INFO -     getExpected@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:62:7
13:38:55     INFO -     getListener/<@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:236:22
13:38:55     INFO -     
13:38:55     INFO - onBeforeSendHeaders 48 http://mochi.test:8888/favicon.ico
13:38:55     INFO - Not taking screenshot here: see the one that was previously logged
13:38:55     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico 
13:38:55     INFO -     getExpected@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:62:7
13:38:55     INFO -     getListener/<@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:236:22
13:38:55     INFO -     
13:38:55     INFO - onSendHeaders 48 http://mochi.test:8888/favicon.ico
13:38:55     INFO - Not taking screenshot here: see the one that was previously logged
13:38:55     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico 
13:38:55     INFO -     getExpected@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:62:7
13:38:55     INFO -     getListener/<@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:236:22
13:38:55     INFO -     
13:38:55     INFO - onHeadersReceived 48 http://mochi.test:8888/favicon.ico
13:38:55     INFO - Not taking screenshot here: see the one that was previously logged
13:38:55     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico 
13:38:55     INFO -     getExpected@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:62:7
13:38:55     INFO -     getListener/<@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:236:22
13:38:55     INFO -     
13:38:55     INFO - onResponseStarted 48 http://mochi.test:8888/favicon.ico
13:38:55     INFO - Not taking screenshot here: see the one that was previously logged
13:38:55     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico 
13:38:55     INFO -     getExpected@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:62:7
13:38:55     INFO -     getListener/<@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:236:22
13:38:55     INFO -     
13:38:55     INFO - onCompleted 48 http://mochi.test:8888/favicon.ico
13:38:55     INFO - Not taking screenshot here: see the one that was previously logged
13:38:55     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_webrequest_filter.html | unexpected request favicon.ico 
13:38:55     INFO -     getExpected@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:62:7
13:38:55     INFO -     getListener/<@moz-extension://8836590f-8423-5747-97f6-d71a53048e42/%7B925a4cf3-92ca-d146-b5fe-7b71b6e07f70%7D.js:236:22
13:38:55     INFO -     
13:38:55     INFO - GECKO(1054) | ++DOMWINDOW == 22 (0x11b323c00) [pid = 1055] [serial = 343] [outer = 0x11e3c6200]
13:38:55     INFO - GECKO(1054) | [Child 1055, Main Thread] WARNING: '!window', file /builds/worker/workspace/build/src/dom/cache/CacheStorage.cpp, line 596
13:38:55     INFO - GECKO(1054) | [Child 1055, Main Thread] WARNING: A runnable was posted to a worker that is already shutting down!: file /builds/worker/workspace/build/src/dom/workers/WorkerPrivate.cpp, line 1582
13:38:55     INFO - GECKO(1054) | [Child 1065, Main Thread] WARNING: '!window', file /builds/worker/workspace/build/src/dom/cache/CacheStorage.cpp, line 596
13:38:55     INFO - GECKO(1054) | [Parent 1054, Main Thread] WARNING: '!window', file /builds/worker/workspace/build/src/dom/cache/CacheStorage.cpp, line 596
13:38:55     INFO - GECKO(1054) | [Child 1056, Main Thread] WARNING: '!window', file /builds/worker/workspace/build/src/dom/cache/CacheStorage.cpp, line 596
Whiteboard: [retriggered]
See Also: → 1485467
There are 74 occurrence for this failure in the last 7 days. This is happening on the debug builds on all platforms.

:ddurst can you take a look at this?
Flags: needinfo?(ddurst)
Whiteboard: [retriggered] → [retriggered] [stockwell needswork]
Shane, could you take a look? (also related: bug 1485467 ).

I think that we have to add an expectation for favicons to test_webRequest_filter_tab, like this:
https://searchfox.org/mozilla-central/rev/55da592d85c2baf8d8818010c41d9738c97013d2/toolkit/components/extensions/test/mochitest/test_ext_webrequest_filter.html#81-88

But the comments around optional_events refer to bug 1472156, which suggests that optional_events are only supposed to happen in non-e10s. That is at odds with this bug, where the test failure clearly occurs with e10s.
Flags: needinfo?(ddurst) → needinfo?(mixedpuppy)
(In reply to Rob Wu [:robwu] from comment #7)
> Shane, could you take a look? (also related: bug 1485467 ).
> 
> I think that we have to add an expectation for favicons to
> test_webRequest_filter_tab, like this:
> https://searchfox.org/mozilla-central/rev/
> 55da592d85c2baf8d8818010c41d9738c97013d2/toolkit/components/extensions/test/
> mochitest/test_ext_webrequest_filter.html#81-88

yeah.

> But the comments around optional_events refer to bug 1472156, which suggests
> that optional_events are only supposed to happen in non-e10s. That is at
> odds with this bug, where the test failure clearly occurs with e10s.

Used to be the case, but at some point that changed.
Flags: needinfo?(mixedpuppy)
I can consistently reproduce this bug by adding an artificial wait before resetting the window location to about:blank.

I've looked at the list of failures, and it seems that the requests either end up being aborted (onErrorOccurred) or they complete (onCompleted). This seems different from test_webRequest_filter_window, where the final requests are somehow not observed. That does probably still require an investigation (bug 1472156).
Assignee: nobody → rob
Status: NEW → ASSIGNED
Duplicate of this bug: 1485467
Comment on attachment 9005139 [details]
Bug 1484062 - Add optional favicon.ico expectation to test_ext_webrequest_filter.html

Shane Caraveo (:mixedpuppy) has approved the revision.
Attachment #9005139 - Flags: review+
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/cd5cb85fa128
Add optional favicon.ico expectation to test_ext_webrequest_filter.html r=mixedpuppy
https://hg.mozilla.org/mozilla-central/rev/cd5cb85fa128
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Flags: qe-verify-
Whiteboard: [retriggered] [stockwell disable-recommended] → [retriggered] [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.