Add more explanation to certificate errors caused by Symantec distrust

RESOLVED FIXED in Firefox 63

Status

()

P1
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: johannh, Assigned: johannh)

Tracking

(Blocks: 2 bugs)

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 months ago
Given the amount of reactions to the Symantec distrust on Nightly and the likelihood that sites will continue to be broken into the beta cycle (and a possible long tail staying broken in release), we want to add more context to certificate error pages that result from the Symantec distrust.

Meridel added new copy here: https://docs.google.com/document/d/1PGZFR5fpXAjwJ8B3zg7wmZENYrDL3gWj9qmetJC2XFk/edit#bookmark=id.scha6getph5

which is pending review by Wayne.
Johann, not sure if this would fall within this task - I just got stuck due to the size of the frame with a distrust warning and no option to get to the buttons: https://screenshots.firefox.com/UJZpXJEAuTyvCgZS/contact.ebay.com.au
See Also: → bug 1409257
Blocks: 1409257
No longer blocks: 1485321
(Assignee)

Comment 4

7 months ago
(In reply to Albert Scheiner [:alberts] from comment #1)
> Johann, not sure if this would fall within this task - I just got stuck due
> to the size of the frame with a distrust warning and no option to get to the
> buttons: https://screenshots.firefox.com/UJZpXJEAuTyvCgZS/contact.ebay.com.au

Can you please file a new bug for this in the Firefox::Security component? Thank you!
> Can you please file a new bug for this in the Firefox::Security component?
> Thank you!Bug 1485670

Comment 6

7 months ago
Comment on attachment 9002739 [details]
Bug 1484246 - Part 1 - Add more explanation to certificate errors caused by Symantec distrust. r=Gijs,keeler

:Gijs (he/him) has approved the revision.
Attachment #9002739 - Flags: review+
Comment on attachment 9002739 [details]
Bug 1484246 - Part 1 - Add more explanation to certificate errors caused by Symantec distrust. r=Gijs,keeler

[:keeler] (use needinfo) has approved the revision.
Attachment #9002739 - Flags: review+
Attachment #9002739 - Attachment description: Bug 1484246 - Add more explanation to certificate errors caused by Symantec distrust. r=Gijs,keeler → Bug 1484246 - Part 1 - Add more explanation to certificate errors caused by Symantec distrust. r=Gijs,keeler
Comment on attachment 9004079 [details]
Bug 1484246 - Part 2 - Add more explanation to certificate errors caused by Symantec distrust to Fennec. r=snorp

James Willcox (:snorp) (jwillcox@mozilla.com) has approved the revision.
Attachment #9004079 - Flags: review+
(Assignee)

Comment 11

7 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee065e7ebc574e1e31c1194fcba8772fe2dc3d9c
Bug 1484246 - Part 1 - Add more explanation to certificate errors caused by Symantec distrust. r=Gijs,keeler

https://hg.mozilla.org/integration/mozilla-inbound/rev/ebb3dfbeaee88ce71a5287de5c97cbc6a5fbede2
Bug 1484246 - Part 2 - Add more explanation to certificate errors caused by Symantec distrust to Fennec. r=snorp

Comment 12

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ee065e7ebc57
https://hg.mozilla.org/mozilla-central/rev/ebb3dfbeaee8
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63

Updated

7 months ago
Depends on: 1488098
Duplicate of this bug: 1483208
You need to log in before you can comment on or make changes to this bug.