Closed Bug 1484330 Opened 6 years ago Closed 6 years ago

Crash in static void std::alloc::rust_oom | static struct webrender::clip::ClipItemRange webrender::clip::ClipStore::add_clip_items

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
thunderbird_esr60 --- unaffected
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- disabled

People

(Reporter: calixte, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-88ffe056-f98c-465a-828e-e45690180817.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll static void std::alloc::rust_oom src/libstd/alloc.rs:137
1 xul.dll static struct webrender::clip::ClipItemRange webrender::clip::ClipStore::add_clip_items gfx/webrender/src/clip.rs:406
2 xul.dll static struct webrender::clip::ClipChainId webrender::display_list_flattener::DisplayListFlattener::add_clip_node<webrender::clip::ComplexTranslateIter<webrender_api::display_list::AuxIter<webrender_api::display_item::ComplexClipRegion>>> gfx/webrender/src/display_list_flattener.rs:1315
3 xul.dll static union core::option::Option<webrender_api::display_list::BuiltDisplayListIter> webrender::display_list_flattener::DisplayListFlattener::flatten_item gfx/webrender/src/display_list_flattener.rs:709
4 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_items gfx/webrender/src/display_list_flattener.rs:297
5 xul.dll static union core::option::Option<webrender_api::display_list::BuiltDisplayListIter> webrender::display_list_flattener::DisplayListFlattener::flatten_item gfx/webrender/src/display_list_flattener.rs:618
6  @0xecef27e2af 
7 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_items gfx/webrender/src/display_list_flattener.rs:297
8 xul.dll static void webrender::display_list_flattener::DisplayListFlattener::flatten_root gfx/webrender/src/display_list_flattener.rs:260
9 xul.dll static struct webrender::frame_builder::FrameBuilder webrender::display_list_flattener::DisplayListFlattener::create_frame_builder gfx/webrender/src/display_list_flattener.rs:183

=============================================================

There is 1 crash in nightly 63 with buildid 20180817100105. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1481570.

[1] https://hg.mozilla.org/mozilla-central/rev?node=7846bdd3762c
Flags: needinfo?(jmuizelaar)
Blocks: wr-stability
Flags: needinfo?(jmuizelaar)
Priority: -- → P3
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.