Closed Bug 148445 Opened 18 years ago Closed 18 years ago

xul popup truncate text

Categories

(Core :: XUL, defect)

x86
Windows NT
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 135089

People

(Reporter: ftang, Assigned: bryner)

References

Details

(Keywords: intl)

Attachments

(1 file)

in the moderm theme, the popup is measure as the longest menu item, but it will
also put a [V] click button in the right hand side. so we will always truncate
the text for the longest menu item. 

For example, 
1.. open preference, Mail&Newsgroup. Message Display
2. change the Style setting from "Regular" to "Bold Italic", the 'Bold Italic"
will be displayed as "Bold Ital..."

This make the localization look very bad. The bug impact also english. It make
the menu display truncation everytime the popup IS set to the longest menu item.
rchen, please attach screen shot for both English and Chinese 
Blocks: 141008
Keywords: intl, nsbeta1+
Summary: xul popup truncate text → xul popup truncate text
I think this should be nsbeta1+
Keywords: nsbeta1+nsbeta1
For detail of Chinese bug, see http://bugscape.netscape.com/show_bug.cgi?id=15746
If the items in list are in the same length and short (for example 4
characters), the box will display "..." after user selects the item. 
reassign to     jkeiser@netscape.com  
Assignee: hyatt → jkeiser
Is this happening in current trunk? It sounds a lot like bug 135089, but that 
is fixed in the trunk.
This is XUL dropdown, not HTML.  Reassigning to default component owner of XUL
widgets.
Assignee: jkeiser → hyatt
Component: XP Toolkit/Widgets: Menus → XP Toolkit/Widgets: XUL
Hyatt's on sabbatical, trying bryner.

/be
Assignee: hyatt → bryner
cc mcarlson and yxia.
looks like a dup of 135089 dup it.

*** This bug has been marked as a duplicate of 135089 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Blocks: 146292
No longer blocks: 141008
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.