Closed Bug 1484577 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 12565 - [wptserver] Correct value in unit test

Categories

(Testing :: web-platform-tests, enhancement, P4)

enhancement

Tracking

(firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 12565 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/12565
Details from upstream follow.

Mike Pennisi <mike@mikepennisi.com> wrote:
>  [wptserver] Correct value in unit test
>  
>  This correction was previously submitted via gh-12459. Since the patch which that pull request intended to fix has since been reverted, it's unclear if/how the pull request can be accepted. I'm re-submitting the commit in a dedicated pull request because it corrects an unrelated mistake.
>  
>  Since this concerns a Windows-specific codepath, TravisCI won't be able to validate the change. The following code may be manually inserted into the test module to verify expected behavior using a non-Windows system:
>  
>  ```python
>  def uname():
>      return ('Windows',)
>  platform.uname = uname
>  ```
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e8799b402ec
[wpt PR 12565] - [wptserver] Correct value in unit test, a=testonly
https://hg.mozilla.org/mozilla-central/rev/7e8799b402ec
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.