Closed Bug 148461 Opened 18 years ago Closed 18 years ago

order / sort and view on multiple message parameters

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

x86
All
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 57898

People

(Reporter: ellisteer_box8003, Assigned: sspitzer)

References

Details

Mozilla/5.0 rv:1.0rc3 Gecko/20020523

You should be able order and view messages based on multiple parameters chosen
by the user.  Currently you can only select one parameter such as date received
or label when ordering messages.  Some additional ordering occurs automatically
depending on the category you choose.  And you can only filter the message view
based on if a message is read, unread, threaded, or watched.

For example a user should be able to say, 

1) sort messages by label then date (a general double category sort)

2) sort messages by unread then labeled (i.e. this would allow users to have
unread messages shown first followed by messages labeled by priority)

3) only view messages unread and labeled important

4) only view message from a certain sender

Or whatever way a user prefers to filter the view and define the sort order.

A suggestion for implementing the multiple category sort is to add an item to
the "View -> Sort By" menu called "Custom..." or "Multiple..." which opens a
dialog box like the dialog used to define mail filters rules  (seen in Tools ->
Message Filters-> (select filter name) Edit -> Filter Rules).  This item would
display checked if a custom category sort is current to that folder.  If a user
clicks on a category heading in the message view or selects a single category in
the existing "View -> Sort By" menu then that custom sort is unchecked.

A similar thing could be done to filter which messages are displayed in the
viewer.  The availible parameters to choose to filter the view by should include
the same ones used for ordering.

-Ellis
*** Bug 148454 has been marked as a duplicate of this bug. ***
Summary: multiple order / sort and view parameters → order / sort and view on multiple message parameters
marking as enhancement and new
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
I agree, but I think there is a simpler UI.  I'd like to click first on 'sort by
name', then 'flag' and have it sorted first by flag then by name.  I see no
reason for a special menu item.

*** This bug has been marked as a duplicate of 57898 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.