Ban "-dt-*" (bitmap!!) fonts from Xprint

RESOLVED FIXED in mozilla1.0.1

Status

--
blocker
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: roland.mainz, Assigned: roland.mainz)

Tracking

Trunk
mozilla1.0.1
Sun
Solaris
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
[Spin-off of bug 147743 ("Xprint prints some (non-scaleable) bitmap fonts far
too small")]:
We need to "ban" all the "-dt-*" aliases from Xprint since they will be the
default fonts for the Solaris version of Netscape but are _all_ bitmap fonts
(BAD).
(Assignee)

Updated

17 years ago
Depends on: 148468
(Assignee)

Comment 1

17 years ago
Taking myself...
Assignee: katakai → Roland.Mainz
QA Contact: Roland.Mainz → katakai
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 2

17 years ago
Created attachment 85866 [details] [diff] [review]
Patch for 2002-05-24-08-trunk
(Assignee)

Comment 3

17 years ago
Requesting r=/sr=/a{1.0.1}= ...
Keywords: approval, mozilla1.0.1, patch, review
(Assignee)

Updated

17 years ago
Blocks: 147743

Updated

17 years ago
Attachment #85866 - Flags: review+

Comment 4

17 years ago
I am not very familiar with xprint issues. I understood why you want to add
"dt*" to rejection list. Could you explain if there is any possible negative
impact by removing "-urw.*;scalable=false;" from rejection list? r=shanjian if
you are confident with the consequence.  

(Assignee)

Comment 5

17 years ago
Shanjian Li wrote:
> I am not very familiar with xprint issues.

It's a quality issue.
Xprint can use both scaleable outline fonts (printer-builtin fonts and PS Type1;
Solaris Xprt can use TrueType, too (TrueType support for Linux Xprt comes ~~
next month)) and bitmap fonts (this is a feature (see the "myths" section in the
Xprint FAQ
(http://puck.informatik.med.uni-giessen.de/people/gisburn/work/xprint/Xprint_FAQ.txt)
- some people tend to use this feature to shoot against Xprint... ;-( ) which
makes it possible to print _anything_ even if you do not have matching fonts).
However forcing _always_ bitmap fonts will make the printout quality worse than
neccesary. Since all the "-dt-*" fonts are bitmap fonts the Xprint module will
prefer them even when there are better-looking scaleable outline fonts available
(I think this is a bug in our fontmetrics system).

> I understood why you want to add
> "dt*" to rejection list. Could you explain if there is any possible negative
> impact by removing "-urw.*;scalable=false;" from rejection list?

Well, it was never enabled due the performance regression caused by that code on
the main display (I am going to fix that soon, maybe this week) - however I
personally do not care if the initalisation of the Xprint module (e.g. the first
time when it's being used) takes 1sec more with the ban enabled (main display is
not affected).
I did not had problems with the URW fonts yet nor was the ban "active" yet,
therefore I can live with the consequences... :)

> r=shanjian if
> you are confident with the consequence. 

Yup, I am confident.
Comment on attachment 85866 [details] [diff] [review]
Patch for 2002-05-24-08-trunk

sr=jst
Attachment #85866 - Flags: superreview+
(Assignee)

Updated

17 years ago
Blocks: 149768
(Assignee)

Updated

17 years ago
Blocks: 150519
(Assignee)

Updated

17 years ago
No longer blocks: 150519
Checked in to trunk for Roland
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

17 years ago
Requesting a= for 1.0.1-branch...
Comment on attachment 85866 [details] [diff] [review]
Patch for 2002-05-24-08-trunk

Approved for 1.0 branch.  Please remove mozilla1.0.1+ when it's fixed and add
fixed1.0.1
Attachment #85866 - Flags: approval+

Updated

17 years ago
Keywords: approval, mozilla1.0.1, review → mozilla1.0.1+
Checked in to branch
Keywords: mozilla1.0.1+ → fixed1.0.1
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.