Images with a leading space in the URL won't render in page.

VERIFIED DUPLICATE of bug 87894

Status

()

Core
Layout
--
major
VERIFIED DUPLICATE of bug 87894
16 years ago
16 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Build ID: latest 5-31-2002 trunk and branch builds.

Summary: Images with a leading space in the URL won't render in page.

Steps to Reproduce:

1. Load
http://www.comp.autosite.com/lexusweb/c-compbottom.asp?LexTrim=9560&CompTrim=9587&VehMod=2740&Lex=&Session_Id=&AdvOnly=&TxtAdvOnly=&CompType=1&SaveBtn=

Expected Results:

You should see an image of an IS 300 on the left, and a BMW on the right.

Actual Results:

You see broken image placeholders, because we're not parsing the URL correctly.

Here is a breakdown of the URLS:

The full path of the IS 300 image is
http://www.comp.autosite.com/lexusweb/images/clientphoto/9560.gif

The relative path is
<img src=" images/clientphoto/9560.gif" width="140" height="67" border="0"
alt="Lexus">

This works fine in IE 6 and Netscape 4.7x - most likely they just escape that
leading space.

Other observations:

When I 'View Image', this works fine, most likely because we use the full path.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 87894 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Sorry about that; query wasn't savvy enough, I suppose.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.