Closed Bug 1484863 Opened Last year Closed 2 months ago

Bad layerization of https://buddhapizza.com/

Categories

(Core :: Graphics: WebRender, enhancement, P2)

63 Branch
enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox63 --- affected

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Blocks 2 open bugs)

Details

It looks like we should be able to separate out this animation nicely. Unfortunately, that doesn't seem to be happening.
Priority: -- → P2
Blocks: wr-perf
Assignee: nobody → jmuizelaar
Depends on: blob-recoord
It looks like this is probably caused by bounds changes that should be helped by blob recoordination
Assignee: jmuizelaar → a.beingessner
Assignee: a.beingessner → nical.bugzilla
We're pretty bad at this on non-webrender. I'll re-profile.
Flags: needinfo?(jmuizelaar)
Priority: P2 → P4

This still looks pretty bad.

Flags: needinfo?(jmuizelaar)
Assignee: nical.bugzilla → nobody
Assignee: nobody → jmuizelaar
Blocks: wr-68
No longer blocks: stage-wr-trains
Priority: P4 → P2
Blocks: wr-69
No longer blocks: wr-68
Blocks: wr-70
No longer blocks: wr-69
Blocks: wr-71
No longer blocks: wr-70

On this page, the optimization from bug 1583879 helps even with Jeff's blob splitting changes.

I'd say this is good enough now.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.