Closed Bug 1484906 Opened 4 years ago Closed 4 years ago

Need Permissions to upload Flash Player symbols

Categories

(Tecken :: General, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: viveknegi1, Assigned: peterbe)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36

Steps to reproduce:

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.162 Safari/537.36

Steps to reproduce:

I am a member of Flash Runtime Team , noida. 
I need to have elevated permissions to upload Flash Player symbols to mozilla. Previously Suriti used to upload symbols but from now on I will be doing this task.  









Actual results:

Permission denied. 



Expected results:

Permission should be allotted.
Vivek will be uploading Flash symbols from now on. Please assign the upload access to him. I vouch for him.
Switching this to Tecken since that's the system that does symbols now.
Component: Symbols → Tecken Integration
Assignee: nobody → peterbe
Hi Vivek, for me to be able to give you the elevated permission you need to sign in at least one time with your Adobe email address. Then I can find you and give you permission.
Hi Peter,

This is my account linked with my adobe email address.
Thanks but you need to go to https://symbols.mozilla.org/ at least once and log in, with that email address. I can't give you permission unless you already exist. For a brief moment, you'll have an account but with no permissions.
I have logged-in into the symbols.mozilla.org using vnegi@adobe.com. Please provide me the elevated permissions.
Vivek, 
Thanks! You're now part of the Uploaders group.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Hi Peter,

I am using the latest dump_syms ( dump_syms_vc1800) tool present at here https://hg.mozilla.org/mozilla-central/file/tip/toolkit/crashreporter/tools/win32.When i am trying to upload the .sym file to mozilla symbols repository, it says : " Unrecognized file pattern. Should only be <module>/<hex>/<file> or <name>-symbols.txt and nothing else." 
Can you help me in this ?

-Vivek
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Hi Vivek, 
This bug was about giving out the right permissions. If you have problems generating symbols let's start a new bug specifically for that. You can click the "New/Clone Bug --> ...in this component" button here in the lower right-hand corner. 

Even if your query isn't a "bug" it's good to file it because clearly, the instructions [0][1] are good enough and perhaps by listening to your issue we can improve the documentation etc. 


[0] https://tecken.readthedocs.io/en/latest/upload.html
[1] https://symbols.mozilla.org/help
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED

Moving from Socorro product to Tecken product.

Component: Tecken → General
Product: Socorro → Tecken
You need to log in before you can comment on or make changes to this bug.