Closed Bug 1484912 Opened Last year Closed Last year

Middle click on @search Top Site highlights the previously clicked one

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox61 --- unaffected
firefox62 --- wontfix
firefox63 --- affected

People

(Reporter: cfogel, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, uiwanted)

Attachments

(1 file)

[Affected versions]:
- 62.0b18, 63.0a1 (2018-08-20) 

[Affected platforms]:
- Win 10x64, Ubuntu 18.04LTS, macOS 10.11

[Steps to reproduce]:
- have at least 2 search engines added in the top-sites section
1. Launch Firefox;
2. Open the new-tab page;
3. Click on any  search engine;
4. Middle click on any other search engine.

[Expected result]:
- search and shortcut is performed with the desired search-engine;
- the search engine mentioned at step 4 is highlighted only;

[Actual result]:
- the search engine from step 3 is highlighted on middle-click

[Regression range]:
- mozregression bisection points out to:
https://bugzilla.mozilla.org/show_bug.cgi?id=1481590

- pushlog url: 
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7a3737f257d51c78110bbab40017dbb593410518&tochange=d0d2e0f4b33cd28bc05c353c185873256f7f926e
- last good: 2018-08-15 02:59:42.528000
- first bad: 2018-08-15 04:05:24.898000

[Additional notes]:
- attached recording with the issue
Tim, how important is this regression? Thanks!
Flags: needinfo?(tspurway)
Hey Mike, 

As someone without a middle mouse button, i dunno!

I'm marking it 'uiwanted' and we will get an answer soon, though it's safe to say we can't get anything done for 62.
Flags: needinfo?(tspurway)
Keywords: uiwanted
Flags: needinfo?(andrei.br92)
I can confirm the issue but it does not seem important enough to address.
The functionality is correct: the search keyword you click is added in the address bar.
The glitch is only visual and clicking on a topsite with the mouse wheels seems like an accidental action not an intended one.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(andrei.br92)
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.