Can't reload Java applet

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: kazhik, Assigned: alfred.peng)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Java applet at <http://nk-money.topica.ne.jp/kawase/live.html>
doesn't work if you visit there for the second time.

Steps to reproduce:
(1) Load <http://nk-money.topica.ne.jp/kawase/live.html>. Java applet works.
(2) Jump to an another page and come back.

Comment 1

17 years ago
Which build and JRE versions are you using?

Comment 2

17 years ago
User Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.0) Gecko/20020611
Build ID: 2002061103
and
User Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1a) Gecko/20020614
Build ID: 2002061401

Java(TM) Plug-in1.3.1_03

I have the same problem, too.

And I have a similar problem with the Java applets I use at my page
http://www.math.uni-magdeburg.de/~rooff/Schach/18sol.html
Here loading a second time freezes the browser. Worse, with 1.1a the applets
aren't even loaded once when I use the object tag notation, only when the
applet tag is used as at http://private.addcom.de/dxb/dxbpuzz.html it works
for the first loading attempt.

Comment 3

16 years ago
I've had this problem with every applet I've tried on every Mozilla build to
date, including 1.1, on both Windows and Linux.  Restarting Mozilla works; on
Windows it also works if I use the Java Plug-In Console system tray application
to clear the classloader cache. But without one of those two steps, I can only
run a given applet once per session. 

Comment 4

16 years ago
Re-assign to Ping.
Assignee: joe.chou → ping.liao

Comment 5

16 years ago
We have experienced the same problem with the applet that the original reporter
mentions.  This applet is generated by the internal web server in the Canon
VB-C10 network video camera.  The camera itself runs embedded Linux and specs
may be found at http://www.x-zone.canon.co.jp/WebView-E/product/vbc10/index.htm.
 Our configurations are as follows:

Linux 2.4.18, 2.4.19
Mozilla 1.0 Final
Java versions: IBM, Blackdown, Sun (1.3.1, 1.4)

Both kernels and all Java distros do the same thing.  Sometimes the applet will
work properly upon reload.  Most of the time, however, it fails to work after
the first try AND disables the ability to run all other applets until Mozilla is
restarted (or the JavaVM threads are all killed).  

Updated

16 years ago
QA Contact: pmac → petersen

Comment 6

15 years ago
Is this still an issue? Can we get a trace of the Java VM, or the output of the
Java console when this bug happens?

Even the thread status at the time when it won't load any more applets would be
better than nothing.

-M
Keywords: qawanted

Updated

15 years ago
Assignee: ping.liao → kyle.yuan

Comment 7

15 years ago
See Sun's bug 5009809. There is a workaround for this.

Comment 8

15 years ago
See Sun's bug 5009809. There is a workaround for this.

Comment 9

14 years ago
Here is the work around if that matters.

"The issue is when a shift-reload is done in Mozilla, the classes are loaded
from the classloader.  Static classes are reloaded with the last value (or in
one instance corrupt value) which they were set when the previous applet is
destroyed, thus causing the applet to initialize incorrectly.  When creating the
components on a shift-reload, I have to explicitly set static values in methods."

Updated

13 years ago
Assignee: yuanyi21 → pete.zha

Comment 10

13 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng

Comment 11

10 years ago
I can't reproduce anylonger with recent Linux trunk build.
Can anyone confirm this?

Comment 12

10 years ago
It still works for me.
Marking WFM.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090211 Minefield/3.2a1pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.