Closed Bug 1485178 Opened Last year Closed Last year

GeckoView wiping out sharedprefs

Categories

(GeckoView :: General, defect, P1)

defect

Tracking

(geckoview62blocking fixed, firefox-esr52 wontfix, firefox-esr60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox63+ fixed)

RESOLVED FIXED
mozilla63
Tracking Status
geckoview62 blocking fixed
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 + fixed

People

(Reporter: boek, Assigned: droeh)

Details

(Whiteboard: [geckoview:klar:p1][geckoview:klar:beta-blocker])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

Initially reported here.

https://github.com/mozilla-mobile/focus-android/issues/2664


Actual results:

More information here: https://github.com/mozilla-mobile/focus-android/issues/2664#issuecomment-414831194
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [geckoview:klar]
Chris: Potential beta rollout blocker?
Flags: needinfo?(cpeterson)
[geckoview:klar:p1] because this bug should probably block the GV beta rollout.
Flags: needinfo?(cpeterson)
Priority: -- → P1
Whiteboard: [geckoview:klar] → [geckoview:klar:p1]
Assignee: nobody → droeh
This just checks to make sure we don't migrate prefs if we're not in Fennec (and also updates a couple of functions to be private -- as far as I can tell they should already have been). snorp, I think you mentioned killing off the migration code entirely in triage last week; would you rather I went that route (ie, are you sure we don't need it)?
Attachment #9004607 - Flags: review?(snorp)
status-geckoview62=affected because we will want this fix to GECKOVIEW_62_RELBRANCH.
Comment on attachment 9004607 [details] [diff] [review]
Only allow sharedprefs migration if in Fennec

Review of attachment 9004607 [details] [diff] [review]:
-----------------------------------------------------------------

This is fine. I'm really not sure if this is still needed in Fennec. I suspect not, but let's not tempt fate.
Attachment #9004607 - Flags: review?(snorp) → review+
Pushed by droeh@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a6e752d99655
Only migrate sharedprefs when in Fennec. r=snorp
https://hg.mozilla.org/mozilla-central/rev/a6e752d99655
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Dylan, do we need to uplift this fix to the GECKOVIEW_62_RELBRANCH release branch for the Focus Beta? If so, can you please request uplift for approval-mozilla-geckoview62?
Flags: needinfo?(droeh)
Comment on attachment 9004607 [details] [diff] [review]
Only allow sharedprefs migration if in Fennec

[Approval Request Comment]

If this is not a sec:{high,crit} bug, please state case for consideration: N/A

User impact if declined: Switching to GV in Focus can overwrite some Focus shared prefs

Fix Landed on Version: 63

Risk to taking this patch (and alternatives if risky): Minimal risk -- we still run the same exact code as before when in Fennec, behavior should only be different (and correct) in GV apps

String or UUID changes made by this patch: None

See https://wiki.mozilla.org/Release_Management/Uplift_rules for more info.
Flags: needinfo?(droeh)
Attachment #9004607 - Flags: approval-mozilla-geckoview62?
This bug is a Focus Beta blocker.
Whiteboard: [geckoview:klar:p1] → [geckoview:klar:p1][geckoview:klar:beta-blocker]
Comment on attachment 9004607 [details] [diff] [review]
Only allow sharedprefs migration if in Fennec

Blocks Focus beta, GV62+
Attachment #9004607 - Flags: approval-mozilla-geckoview62? → approval-mozilla-geckoview62+
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 63 → mozilla63
You need to log in before you can comment on or make changes to this bug.