Crash in static void PurgeWRGlyphAtlas

RESOLVED FIXED in Firefox 63

Status

()

--
critical
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: calixte, Assigned: lsalzman)

Tracking

(Blocks: 2 bugs, {crash, regression})

Trunk
mozilla63
Unspecified
Windows 10
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 fixed)

Details

(crash signature)

(Reporter)

Description

3 months ago
This bug was filed from the Socorro interface and is
report bp-aca1a799-bcee-4268-b5ff-49fdd0180822.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll static void PurgeWRGlyphAtlas gfx/thebes/gfxFontMissingGlyphs.cpp:236
1 xul.dll gfxPlatform::OnMemoryPressure gfx/thebes/gfxPlatform.cpp:474
2 xul.dll mozilla::layers::MemoryPressureObserver::Observe gfx/layers/MemoryPressureObserver.cpp:67
3 xul.dll nsObserverService::NotifyObservers xpcom/ds/nsObserverService.cpp:295
4 xul.dll mozilla::dom::ContentChild::RecvFlushMemory dom/ipc/ContentChild.cpp:2747
5 xul.dll mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:7348
6 xul.dll void mozilla::ipc::MessageChannel::DispatchMessageW ipc/glue/MessageChannel.cpp:2166
7 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:2045
8 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1167
9 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:519

=============================================================

There are 2 crashes (from 1 installation) in nightly 63 with buildid 20180821220101. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1479196.

[1] https://hg.mozilla.org/mozilla-central/rev?node=07dabfefeef1
Flags: needinfo?(lsalzman)
Blocks: 1357819

Comment 1

3 months ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4621d2fd3f17
fix purging of missing glyph WebRender users. r=me
(Assignee)

Updated

3 months ago
Duplicate of this bug: 1485360
(Assignee)

Updated

3 months ago
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Flags: needinfo?(lsalzman)

Comment 3

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4621d2fd3f17
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Crash Signature: [@ static void PurgeWRGlyphAtlas] → [@ static void PurgeWRGlyphAtlas] [@ PurgeWRGlyphAtlas]
Duplicate of this bug: 1485397
You need to log in before you can comment on or make changes to this bug.