Crash in gfxFontMissingGlyphs::Shutdown

RESOLVED DUPLICATE of bug 1485358

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1485358
9 months ago
7 months ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks 2 bugs, {crash, regression})

Trunk
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 fixed)

Details

(crash signature)

Reporter

Description

9 months ago
This bug was filed from the Socorro interface and is
report bp-6633c438-2603-43f1-b7b7-0a3e90180822.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so gfxFontMissingGlyphs::Shutdown mfbt/LinkedList.h:325
1 libxul.so gfxPlatform::OnMemoryPressure gfx/thebes/gfxPlatform.cpp:474
2 libxul.so mozilla::layers::MemoryPressureObserver::Observe gfx/layers/MemoryPressureObserver.cpp:67
3 libxul.so nsObserverService::NotifyObservers xpcom/ds/nsObserverList.cpp:112
4 libxul.so MinimizeMemoryUsageRunnable::Run xpcom/base/nsMemoryReporterManager.cpp:2773
5 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1167
6 libxul.so NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:519
7 libxul.so mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:97
8 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:325
9 libxul.so nsBaseAppShell::Run widget/nsBaseAppShell.cpp:158

=============================================================

There is 1 crash in nightly 63 with buildid 20180821220101. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1479196.

[1] https://hg.mozilla.org/mozilla-central/rev?node=07dabfefeef1
Flags: needinfo?(lsalzman)
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(lsalzman)
Resolution: --- → DUPLICATE
Duplicate of bug: 1485358
You need to log in before you can comment on or make changes to this bug.