Closed Bug 1485384 Opened 2 years ago Closed 2 years ago

Intermittent Error in open_allowCallsWhileClosed(org.mozilla.geckoview.test.SessionLifecycleTest) | org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed | status -2

Categories

(GeckoView :: General, defect, P5)

defect

Tracking

(firefox62 fixed, firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jchen)

References

Details

Attachments

(1 file)

Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=195303740&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/bKpwN6iwSG2g-_QQ5qjMhA/runs/0/artifacts/public/logs/live_backing.log

[task 2018-08-22T14:51:10.327Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2018-08-22T14:51:10.327Z] 14:51:10  WARNING -  TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed | status -2
[task 2018-08-22T14:51:10.328Z] 14:51:10     INFO -  TEST-INFO took 124584ms
[task 2018-08-22T14:51:10.328Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2018-08-22T14:51:10.329Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=133
[task 2018-08-22T14:51:10.329Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.SessionLifecycleTest
[task 2018-08-22T14:51:10.330Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2018-08-22T14:51:10.331Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=143
[task 2018-08-22T14:51:10.331Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=readFromParcel_closedSession
[task 2018-08-22T14:51:10.332Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: 1
[task 2018-08-22T14:49:05.730Z] 14:49:05     INFO -  TEST-START | org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed
[task 2018-08-22T14:51:10.204Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2018-08-22T14:51:10.205Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=132
[task 2018-08-22T14:51:10.206Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.SessionLifecycleTest
[task 2018-08-22T14:51:10.207Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2018-08-22T14:51:10.208Z] 14:51:10     INFO -  org.mozilla.geckoview.test | Error in open_allowCallsWhileClosed(org.mozilla.geckoview.test.SessionLifecycleTest):
[task 2018-08-22T14:51:10.208Z] 14:51:10     INFO -  org.mozilla.geckoview.test | org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2018-08-22T14:51:10.209Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:48)
[task 2018-08-22T14:51:10.209Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-08-22T14:51:10.210Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-08-22T14:51:10.210Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:100)
[task 2018-08-22T14:51:10.210Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitUntilCalled(GeckoSessionTestRule.java:1735)
[task 2018-08-22T14:51:10.211Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForPageStops(GeckoSessionTestRule.java:1540)
[task 2018-08-22T14:51:10.211Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.BaseSessionTest.waitForPageStops(BaseSessionTest.kt:102)
[task 2018-08-22T14:51:10.212Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed(SessionLifecycleTest.kt:54)
[task 2018-08-22T14:51:10.212Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-08-22T14:51:10.213Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-08-22T14:51:10.213Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2018-08-22T14:51:10.213Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2018-08-22T14:51:10.213Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2018-08-22T14:51:10.214Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2018-08-22T14:51:10.214Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$4.evaluate(GeckoSessionTestRule.java:1486)
[task 2018-08-22T14:51:10.214Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.support.test.internal.statement.UiThreadStatement$1.run(UiThreadStatement.java:44)
[task 2018-08-22T14:51:10.214Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-08-22T14:51:10.215Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-08-22T14:51:10.215Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-08-22T14:51:10.215Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-08-22T14:51:10.215Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-08-22T14:51:10.216Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-08-22T14:51:10.216Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-08-22T14:51:10.217Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-08-22T14:51:10.217Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-08-22T14:51:10.217Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-08-22T14:51:10.217Z] 14:51:10     INFO -  org.mozilla.geckoview.test |
[task 2018-08-22T14:51:10.217Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=143
[task 2018-08-22T14:51:10.305Z] 14:51:10     INFO -  org.mozilla.geckoview.test |
[task 2018-08-22T14:51:10.306Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2018-08-22T14:51:10.307Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:48)
[task 2018-08-22T14:51:10.308Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-08-22T14:51:10.309Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-08-22T14:51:10.310Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:100)
[task 2018-08-22T14:51:10.311Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitUntilCalled(GeckoSessionTestRule.java:1735)
[task 2018-08-22T14:51:10.312Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForPageStops(GeckoSessionTestRule.java:1540)
[task 2018-08-22T14:51:10.313Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.BaseSessionTest.waitForPageStops(BaseSessionTest.kt:102)
[task 2018-08-22T14:51:10.314Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed(SessionLifecycleTest.kt:54)
[task 2018-08-22T14:51:10.314Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-08-22T14:51:10.315Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-08-22T14:51:10.316Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2018-08-22T14:51:10.316Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2018-08-22T14:51:10.317Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2018-08-22T14:51:10.317Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2018-08-22T14:51:10.318Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$4.evaluate(GeckoSessionTestRule.java:1486)
[task 2018-08-22T14:51:10.318Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.support.test.internal.statement.UiThreadStatement$1.run(UiThreadStatement.java:44)
[task 2018-08-22T14:51:10.319Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-08-22T14:51:10.320Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-08-22T14:51:10.320Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-08-22T14:51:10.321Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-08-22T14:51:10.322Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-08-22T14:51:10.322Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-08-22T14:51:10.323Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-08-22T14:51:10.324Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-08-22T14:51:10.324Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-08-22T14:51:10.325Z] 14:51:10     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-08-22T14:51:10.325Z] 14:51:10     INFO -  org.mozilla.geckoview.test |
[task 2018-08-22T14:51:10.326Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=open_allowCallsWhileClosed
[task 2018-08-22T14:51:10.327Z] 14:51:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2018-08-22T14:51:10.327Z] 14:51:10  WARNING -  TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed | status -2
[task 2018-08-22T14:51:10.328Z] 14:51:10     INFO -  TEST-INFO took 124584ms
Component: Gecko Profiler → GeckoView
Product: Core → Firefox for Android
Duplicate of this bug: 1485632
Summary: Intermittent org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed | status -2 → Intermittent Error in open_allowCallsWhileClosed(org.mozilla.geckoview.test.SessionLifecycleTest) | org.mozilla.geckoview.test.SessionLifecycleTest.open_allowCallsWhileClosed | status -2
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e9784340c6c
Fix typo in open_allowCallsWhileClosed; r=me
https://hg.mozilla.org/mozilla-central/rev/2e9784340c6c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
(In reply to Arthur Iakab [arthur_iakab] from comment #6)
> Failed here after the merges:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> central&revision=d2da77c319d28b325fc5ceba90fe2c45f5ba84ea&filter-
> resultStatus=testfailed&filter-resultStatus=busted&filter-
> resultStatus=exception&filter-classifiedState=unclassified
> 
> Link to log failure:
> https://treeherder.mozilla.org/logviewer.html#?job_id=195855159&repo=mozilla-
> central

That was actually before the merge from m-i to m-c
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 63 → mozilla63
You need to log in before you can comment on or make changes to this bug.