Closed Bug 1485501 Opened Last year Closed 10 months ago

when devtools is docked to left or right in dual screens mode with different resolutions, door hanger menu is mislocated

Categories

(DevTools :: General, defect, P3, minor)

defect

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: Abe_LV, Assigned: mantaroh)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Steps to reproduce:
Screen capture- https://testing-1.tinytake.com/sf/Mjg1OTUwNF84NTgzMjUz

1. Start nightly on 4K monitor (HiDPI)
2. Open Devtools and dock to left
3. Maximize the browser if it is not
4. Click the meatballs or chevron menu  
5. Observe the door hanger menu location

Expected result:
Door-hanger menu should maintain its location

Actual result:
Door-hanger menu shifts to the right
Update on this bug:
This issue is not reproducible in HiDPI monitor alone or when the two screens have the same resolutions.
But the issue exists when two monitors are used in different resolutions mode. For example, in my case, I have dual monitors, one of them is set to 1920x1080[HD] and the other is set to 3840x2160 [HiDPI]. When this happens, the door-hanger menu gets mislocated.

I do not believe this kind of resolution setting is common or recommended. But the issue is reproducible in this scenario only.
Summary: Door-hanger menu is dislocated in a 4K monitor when devtools is docked to left → when devtools is docked to left or right in dual screens mode with different resolutions, door hanger menu is mislocated
Hi Brian,
I do not consider this as a blocker at level because the issue is reproducible only when two monitors with different resolutions are used. Which is not a common scenario in practical use. But I also believe as this needs to be addressed before it reaches to production. 

What is your opinion on this?
Flags: needinfo?(bbirtles)
(In reply to Abe - QA (:Abe_LV) from comment #2)
> I do not consider this as a blocker at level because the issue is
> reproducible only when two monitors with different resolutions are used.
> Which is not a common scenario in practical use. But I also believe as this
> needs to be addressed before it reaches to production. 

If it needs to be addressed before it reaches production, it's a blocker right?

(FWIW, like you said I don't think it's common enough to be a blocker and we could fix it in a subsequent release but let me try and reproduce the problem locally so see how problematic it is.)
Flags: needinfo?(bbirtles)
I need to order a new cable in order to test with dual displays so I won't get a chance to look at this until next week.
Severity: normal → minor
Priority: -- → P3
I managed to reproduce this on Windows. It only seems to happen when the window is partly in one window and partly in the other. As a result, I think it's fairly low priority.

I also managed to reproduce it in Linux although the symptoms are somewhat different. Given that dual-monitor support with different resolutions in Linux is pretty adventurous territory I'm not too worried about that. Hopefully fixing on Windows would fix it too anyway.

This looks to me to be a day's work or so.
See Also: → 1490285
I think that tooltip which uses the xul wrapper calculated wrong screen and window size. This phenomenon is happened the image tooltip(inspector/netmonitor) and Swatch***Tooltip(Color/Filter/CubicBezier) and FontTooltip as well. I'll look into this.
I think that the screen.availLeft is zero if we displayed the window across the dual display. Then tooltip use the wrong calculated left value. [1]

[1] https://searchfox.org/mozilla-central/rev/819cd31a93fd50b7167979607371878c4d6f18e8/devtools/client/shared/widgets/tooltip/HTMLTooltip.js#628-635
I tried that replacing the viewport rect, if an anchors left position is greater than current viewport right.

https://hg.mozilla.org/try/rev/04b6cf88af01

However, this is an experimental patch, so I need to brush up furthermore.
Assignee: nobody → mantaroh
If we displayed the devtools across the second screen, the Screen.availLeft
might be not zero. I.e., Screen.availLeft point to second screen's left.
The HTMLTooltip does't consider this case, so this patch will change the
viewpor's left and right position if the left of anchor element is bigger than
screen.right.
Status: NEW → ASSIGNED
Pushed by mantaroh@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/70daf386e9d3
Change the calculated viewport if anchor element is displayed at second screen. r=birtles
https://hg.mozilla.org/mozilla-central/rev/70daf386e9d3
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.