Closed Bug 1485510 Opened Last year Closed Last year

Fix mochitests that don't work with CM jsterm enabled

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: bgrins, Assigned: nchevobbe)

References

Details

(Whiteboard: [boogaloo-mvp])

Attachments

(2 files, 1 obsolete file)

As I discovered in https://bugzilla.mozilla.org/show_bug.cgi?id=1463669#c11, after browser_console_consolejsm_output.js happens we never actually run any of the tests with the new jsterm (even when the pref is set).

Fixing this surfaces a number of test failures, like: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f696488a3bb5cbd49ae3f8cc6e61124e920e03c6&selectedJob=195363439. Each of which can be confirmed in a local build by running the test individually. I'm planning to turn off the new frontend for those tests (since it's not running in them anyway), and we can use this bug to fix them.
Priority: -- → P3
Whiteboard: [boogaloo-mvp] → [boogaloo-reserve]
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [boogaloo-reserve] → [boogaloo-mvp]
The completion node was wrongly positionned as soon as the input overflowed.
We fix this by setting the completionNode height in resizeInput,
like we do for the inputNode.

The autocompletionPopup was a bit off due to 2 things:
- in the function that was returning the chevronWidth, we
were substracting the autocomplete popup padding. But the
autocomplete popup already handles that itself.
- in the function that was computing the character width,
we were using offsetWidth which returned a rounded value.
This means that the further the autocompletion was displayed
at, the more the popup would be off. We use getBoundingClientRect().width
instead which gives us a decimal value.

And we also make sure to not alter the scrolling position in the inputNode
when accepting an autocompletion result (a test is added).
TRY push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=74e6e36fb78a0fedc1305c403fd56c75319a6d97

I fixed the eslint failure in the last phabricator review
Comment on attachment 9003771 [details]
Bug 1485510 - Fix mochitests that don't work with CM jsterm enabled; r=bgrins.

Brian Grinstead [:bgrins] has approved the revision.
Attachment #9003771 - Flags: review+
Attachment #9003769 - Attachment is obsolete: true
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6494cda84fc
Fix mochitests that don't work with CM jsterm enabled; r=bgrins.
https://hg.mozilla.org/mozilla-central/rev/b6494cda84fc
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Attachment #9003769 - Attachment is obsolete: false
Should this positioning be fixed by the patch? I'm seeing it both with and without the patch applied.
(In reply to Brian Grinstead [:bgrins] from comment #7)
> Should this positioning be fixed by the patch? I'm seeing it both with and
> without the patch applied.

Also note that this may well have been an existing issue - I'm pretty sure the old jsterm never handled autocomplete on multiline statements well. We don't need to spend a lot of time fixing that if this is the case.
Those last two comments were intended for the "Fix old-jsterm UI glitches" patch which is linked up with this bug. Probably that patch should be attached to a different bug?
Attachment #9003769 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.