Closed Bug 1485515 Opened Last year Closed Last year

TRR: network.trr.mode lacks value range check

Categories

(Core :: Networking: DNS, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: rhpuckett3, Assigned: bagder)

Details

(Whiteboard: [necko-triaged][trr])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

Set "network.trr.mode" = 5 (user disabled) as I did for Firefox 61.0.2.


Actual results:

Thunderbird was unable to resolve host names of incoming / outgoing SMTP hosts. Changed setting to value "0" (off by default) and things worked as expected. Value "4" also worked. Did not try other values 1-3.


Expected results:

Expected behavior similar to Firefox 61.0.2 that TRR is explicitly disabled and client uses regular DNS for resulution.
Because "network.trr.mode" = 5 has been added since Gecko 61. See bug 1453822.
(In reply to Masatoshi Kimura [:emk] from comment #1)
> Because "network.trr.mode" = 5 has been added since Gecko 61. See bug
> 1453822.

Thanks. I thought that was a possibility, but forgot to mention that and didn't see the FF bug you referenced. I don't know if the code bases are shared and wanted to mention this.

In any case, I was surprised that DNS resolution would hang with an unrecognized value (5). I just tried "6" and got the same undesirable behavior - I would have expected it to be ignored and the default used.
(In reply to Rick Puckett from comment #2)
> unrecognized value (5). I just tried "6" and got the same undesirable
> behavior - I would have expected it to be ignored and the default used.

Sure. we should add a range check to "netwerk.trr.mode".
https://dxr.mozilla.org/mozilla-central/rev/5f1db4de173d8d8d160742138c8afc847485bf67/netwerk/dns/TRRService.cpp#138
https://dxr.mozilla.org/mozilla-esr60/rev/dd52b41d2b775e5c7261ce52795268b7670635fc/netwerk/dns/TRRService.cpp#119
Status: UNCONFIRMED → NEW
Component: Untriaged → Networking: DNS
Ever confirmed: true
Product: Thunderbird → Core
Summary: network.trr.mode = 5 prevents DNS resolution → TRR: network.trr.mode lacks value range check
Version: 60 → 60 Branch
Priority: -- → P3
Whiteboard: [necko-triaged][trr]
MozReview-Commit-ID: 8OdeXYQEzQJ
Comment on attachment 9004204 [details]
bug 1485515 - range check the network.trr.mode pref on read

Valentin Gosu [:valentin] has approved the revision.
Attachment #9004204 - Flags: review+
Pushed by daniel@haxx.se:
https://hg.mozilla.org/integration/autoland/rev/c417b2354667
range check the network.trr.mode pref on read r=valentin
https://hg.mozilla.org/mozilla-central/rev/c417b2354667
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → daniel
Version: 60 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.