Print preview scaling non-functional

VERIFIED DUPLICATE of bug 130067

Status

()

Core
Print Preview
--
major
VERIFIED DUPLICATE of bug 130067
16 years ago
16 years ago

People

(Reporter: Jason Greanya, Assigned: rods (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052305

When trying to scale a page for printing using the print preview function,
scaling fails with the "Printing failed for some reason." error dialog.

The "Print Preview" button provided by MacOS X through the standard print dialog
does not duplicate the interactive functionality which your users are looking for.

Because of this scaling issue, the print preview does not reflect the actual
print output and iterative viewing using the OS X Print Preview button is
necessary to fit pages to paper width and length.

Reproducible: Always
Steps to Reproduce:
1. Load a web page (or a text document for that matter)
2. Select print preview.
3. Alter the scale.

Actual Results:  The page fails to scale and a "Printing failed for some
reason." error dialog appears.

Expected Results:  The page scales to the selected value with associated width,
height, image and font size, and number of pages alterations.  This should
duplicate the printed output.

This problem also occurred in the Windows version until the RC2 release, which
is now functional.

Occasionally, which seems page complexity dependent (the more complex the more
probable the extra issue(s)), other symptoms occur:
- Printing becomes non-functional for that particular window, as the print
dialog will not come up at all.  (Closing this window and opening another seems
to clear up this problem.)
- Mozilla itself crashes.  I can't replicate this with any success.  It seems to
happen randomly and is associated with closing a window where print preview
scaling was attempted.

Also, options to add or remove headers and footers and background images seems
missing in the OS X version, unlike the Windows version.  These should be
available as an option in the print dialog in the lowest dropdown.  IE for OS X
has a good example of this functionality.

Comment 1

16 years ago
Confirmed using FizzillaCFM/2002052305 (RC3).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 130067 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.