Closed Bug 1485662 Opened 4 years ago Closed 3 years ago

Design is broken on atticpartyanimals.com while Tracking Protection Basic is enabled

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 62
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-ads][tp-social][tp-content])

User Story

yp.com 
googleapis.com
facebook.com

Attachments

(2 files)

[Environment:]
Browser / Version: Firefox Nightly 63.0a1 (2018-08-22)
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to http://www.atticpartyanimals.com/ 
    2. Observe the page.
        
[Expected Behavior:]
The page content is displayed correctly (images  and css)
 
[Actual Behavior:]
Design is broken (no images and css)
Attached image Brokendesign.png
Added screenshot with broken design.
The issue is related to `trackingprotection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “http://static.sites.yp.com/css/widgets/concat_widget.min.css?v=6.5.1.37806” was blocked because content blocking is enabled.
The resource at “http://connect.facebook.net/en_US/sdk.js” was blocked because content blocking is enabled.
The resource at “http://www.google-analytics.com/analytics.js” was blocked because content blocking is enabled.
The resource at “https://s7.addthis.com/js/250/addthis_widget.js” was blocked because content blocking is enabled.
The resource at “http://sites.yp.com/templates/creator/m_2/2d/2d2/2305/assets/copyright.js” was blocked because content blocking is enabled.
The resource at “https://20587159p.rfihub.com/ca.gif?rb=11869&ca=20587159&ra=2018-08-23%2016:29:31&pgroup=222&cat=Pest%20Control%20Services&custid=1508547595&pubid=&pid=&ptype=&t=” was blocked because content blocking is enabled.

So below are the domains to test:
- static.sites.yp.com
- connect.facebook.net
- www.google-analytics.com
- s7.addthis.com
- sites.yp.com
- 20587159p.rfihub.com

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. The design is broken.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- yp.com (including all related domains)
- ajax.googleapis.com
and the page loads the content correctly with the exception of the video and the embedded Facebook overlay.

I whitelisted:
- facebook.com (including all related domains)
- facebook.net (including all related domains)
- fbcdn.net (including all related domains)
and the embedded Facebook overlay is displayed.

For the video to play I whitelisted:
- ypcdn.com

The other resources didn't help. 

So in conclusion:
- yp.com is in Advertising category = [tp-ads]
- googleapis.com is in Content category = [tp-content]
- facebook.com is in Disconnect category = [tp-social]
- ypcdn.com not listed
User Story: (updated)
Whiteboard: [tp-ads][tp-social][tp-content]
Attached image uMatrixResults.png
Added uMatrix results.
Product: Tech Evangelism → Web Compatibility

The page seems to be working fine now even in strict mode.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.