Closed Bug 1485725 Opened Last year Closed Last year

Fix rtl issues in chiclet UI

Categories

(Firefox :: Messaging System, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 65
Iteration:
65.1 - Nov 2
Tracking Status
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified
firefox66 --- verified

People

(Reporter: ahillier, Assigned: andreio)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

We're only launching the experiment in ltr locales so this can be pushed back slightly but will need to be done later on before wider launch.
Iteration: --- → 64.1 (Sep 14)
Priority: -- → P3
Iteration: 64.1 (Sep 14) → 64.2 (Sep 28)
Iteration: 64.2 (Sep 28) → 65.1 (Nov 2)
See Also: → 1493140
Duplicate of this bug: 1493140
Iteration: 65.1 (Nov 2) → 64.2 (Sep 28)
Priority: P3 → P2
Because we pref'd CFR on in Nightly 64 before finishing l10n/rtl work, users are seeing a broken URL bar.  I am re-prioritizing this bug so that we can fix this sooner, rather than later.
Iteration: 64.2 (Sep 28) → 64.3 (Oct 12)
Assignee: nobody → andrei.br92
Iteration: 64.3 (Oct 12) → 65.1 (Nov 2)
Attached video cfr_rtl.mov
I attached a demo of the RTL animation for CFR. What I did was to flip everything so that the expansion is now left to right.
Flags: needinfo?(amlee)
Flip the animation in RTL mode so we get the same effect
(In reply to Andrei Oprea [:andreio] from comment #3)
> Created attachment 9021291 [details]
> cfr_rtl.mov
> 
> I attached a demo of the RTL animation for CFR. What I did was to flip
> everything so that the expansion is now left to right.

Animation-wise this looks okay I guess, but are you sure the localized text will appear correctly, and not upside-down?
The text is flipped because that is the actual content of the node and not a result of CSS transforms or other style related modifications. I don't think there should be any problems when the content will be localized.
(In reply to Andrei Oprea [:andreio] from comment #3)
> Created attachment 9021291 [details]
> cfr_rtl.mov
> 
> I attached a demo of the RTL animation for CFR. What I did was to flip
> everything so that the expansion is now left to right.

Hi this looks good to me. Thanks
Flags: needinfo?(amlee)
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07930ba778c6
Add RTL support for CFR animation and panel r=ursula
https://hg.mozilla.org/mozilla-central/rev/07930ba778c6
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Does this need an uplift request?
Flags: needinfo?(andrei.br92)
Not required, currently this feature is only available in en-US.
Flags: needinfo?(andrei.br92)
I have verified that this issue is no longer reproducible with the latest Firefox Beta (65.0b7 Build ID - 20181227144402) and with the latest Firefox Nightly (66.0a1 Build ID - 20190102213721) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now the expansion of the "CFR Recommendation" button is from left to right.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.