tabbed browser can get stuck to a redirect URL

VERIFIED WORKSFORME

Status

SeaMonkey
Tabbed Browser
--
minor
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: garym, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/00200205
BuildID:    RC3 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/00200205

This actually works from almost any URL which does a redirect, or that's my
theory: If you mouse-2 click to open a new tab on a page which does a Location
change, the new location becomes stuck; now all mouse-2 new-tab-window clicks on
links will go to the requested site, but then replace it with the stuck URL --
clicking the back button will step back to the requested page.  Right now, that
ORA URL is stuck in my Mozilla, so going to the Mozilla release notes page and
mouse-2 clicking on Bugzilla's link (to get to this page) goes to the bugzilla,
and then jumps again to the ORA page; moving back one page comes back to here. 
This problem has existed since RC1.

I'm only guessing that the ORA page does a 302(?) redirect; the pages that get
stuck do not have any visual similarity or any other common feature -- the
trigger is quite rare (one in a hundred pages?) but once this situation occurs,
the only way out is to restart Mozilla.

Reproducible: Sometimes
Steps to Reproduce:
1.with auto-new-tab set on mouse-2, open a tab to that ORA page
2.open a fresh tab and go to the mozilla release notes
3.mouse-2 to new-tab the Bugzilla link.

step one usually does not get stuck, but once it does, steps 2 and 3 will
reproduce every time.

Actual Results:  the final page is the ORA page, not the bugzilla page; stepping
back in the history reloads the Bugzilla form page.
WFM with trunk 2002073022, linux. reporter: can you reproduce this bug with a
recent build of mozilla (for example, 1.1beta)? if so, please comment again with
details. if not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.