Closed Bug 1485832 Opened 1 year ago Closed 1 year ago

Crash in mozilla::recordreplay::RR_mach_msg

Categories

(Core :: Web Replay, defect, critical)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mccr8, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-4cf7889c-4e01-4600-95f1-4e0770180823.
=============================================================

Top 10 frames of crashing thread:

0  @0x7fff6370a20a 
1 XUL mozilla::recordreplay::RR_mach_msg toolkit/recordreplay/ProcessRedirect.h:119
2 XUL google_breakpad::ReceivePort::WaitForMessage toolkit/crashreporter/google-breakpad/src/common/mac/MachIPC.mm:249
3 XUL google_breakpad::CrashGenerationClient::RequestDumpForException toolkit/crashreporter/breakpad-client/mac/crash_generation/crash_generation_client.cc:77
4 XUL google_breakpad::ExceptionHandler::WriteMinidumpWithException toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:382
5 XUL google_breakpad::ExceptionHandler::WriteForwardedExceptionMinidump toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:651
6 XUL mozilla::recordreplay::child::ReportFatalError toolkit/recordreplay/ipc/ChildIPC.cpp:329
7 XUL RecordReplayInterface_InternalRecordReplayAssert toolkit/recordreplay/ProcessRecordReplay.cpp:474
8 XUL mozilla::recordreplay::RecordReplayAssert mfbt/RecordReplay.h:474
9 XUL mozilla::recordreplay::RR_CFRetain toolkit/recordreplay/ProcessRedirect.h:193

=============================================================


This is showing up in the 8-22 build, which contains the fix for bug 1483365.

Interestingly, this does actually contain a RecordReplayError field:

Assertion Mismatch: Thread 1
Recorded: CFRelease [62737769,31959]
Replayed: CFRetain ### _ZN7mozilla12recordreplayL11RR_CFRetainEm ### _ZN14MacOSFontEntryC2ERK12nsTSubstringIDsEP6CGFontN7mozilla11WeightRangeENS6_12StretchRangeENS6_15SlantStyleRangeEbb ### _ZN22gfxMacPlatformFontList16MakePlatformFontERK12nsTSubstringIDsEN7mozilla11WeightRangeENS4_12StretchRangeENS4_15SlantStyleRangeEPKhj ### _ZN16gfxUserFontEntry16LoadPlatformFontEPKhRj ### _ZN16gfxUserFontEntry24FontDataDownloadCompleteEPKhj8nsresult ### _ZN16nsFontFaceLoader16OnStreamCompleteEP15nsIStreamLoaderP11nsISupports8nsresultjPKh ### _ZN7mozilla3net14nsStreamLoader13OnStopRequestEP10nsIRequestP11nsISupports8nsresult ### _ZN19nsCORSListenerProxy13OnStopRequestEP10nsIRequestP11nsISupports8nsresult ### _ZN7mozilla3net16HttpChannelChild15DoOnStopRequestEP10nsIRequest8nsresultP11nsISupports ### _ZN7mozilla3net16HttpChannelChild13OnStopRequestERK8nsresultRKNS0_20ResourceTimingStructERKNS0_17nsHttpHeaderArrayE ### _ZN7mozilla3net17ChannelEventQueue10FlushQueueEv ###  [62737769,31959]

Here's another crash report with the same signature:
  bp-99301fb7-8da8-458b-811e-e74000180823#tab-metadata

The RecordReplayError looks different for that report, so maybe it is something else?
Flags: needinfo?(bhackett1024)
The CFRetain crash looks like bug 1479921, which I haven't been able to reproduce yet (it might be specific to 10.13, which I haven't upgraded to yet).  The second part looks like it might be fixed by part 3 of bug 1479909, but it's hard to say for sure.
Flags: needinfo?(bhackett1024)

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.