Closed Bug 1485842 Opened Last year Closed 6 months ago

Support hidden prefs in metadata files

Categories

(Testing :: web-platform-tests, enhancement)

enhancement
Not set

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: karlt, Assigned: bzbarsky)

References

Details

Attachments

(1 file)

Prefs that are already defined in all.js or elsewhere can be set in wpt
metadata files, but, when not already defined, the prefs items are silently
ignored, which can be hard to diagnose.

Workaround, once the problem is understood is to define the pref in
testing/profiles/unittest/user.js

(I don't actually know whether this is something to be fixed in the harness or the browser API that the harness uses to set the prefs.)

Workaround, once the problem is understood is to define the pref in
testing/profiles/unittest/user.js

This doesn't actually work properly, because the harness will clearUserPref() between tests. So the result of the current setup is that when I run the webaudio/ wpts on a per-dir basis, I get a bunch of failures in webaudio/idlharness.https.window.html because that test runs second, and the prefs get cleared before it runs. Those failures are marked as expected, of course.

But if I run that test on its own, the prefs take effect and I get a bunch of unexpected passes. Also, if I add "dom.audioworklet.enabled" to StaticPrefList.h I get a bunch of unexpected passes....

Assignee: nobody → bzbarsky
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce21500c025e
Fix pref handling in the wpt harness to deal with prefs that aren't set already. r=jgraham,karlt
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17103 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Upstream PR merged
Regressions: 1556091
No longer regressions: 1556091
Duplicate of this bug: 1395119
You need to log in before you can comment on or make changes to this bug.