Closed Bug 148585 Opened 18 years ago Closed 10 years ago

click() method for links (and other? elements)

Categories

(Core :: DOM: Core & HTML, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 583514

People

(Reporter: frank, Unassigned)

References

Details

The following code doesn't work at all in NS 6.2

<html>
<head>

<script langauge="Javascript">
function go(){
	if (document.getElementById) {

		adest = document.getElementById('destination');
		adest.click();

	}
	else{
		document.anchors[0].click();
	}
}
</script>


</head>
<body onload="go();">

<a href="http://www.whatever.com" name="destination" id="destination"></a>
</body>
</html>
This is really an RFE to implement that method for elements other than the 
traditional button/checkbox/radio/etc., similar to what MSIE provides.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: click() method on an A tag doesn't work at all. → [RFE] implement click() method on an A tag (and other? elements)
Well, I'm not so sure.  It's a part of the DOM
http://www.mozilla.org/docs/dom/domref/dom_el_ref34.html
and since the <A> is the most basic, clickable HTML element, it really should 
be available.
QA Contact: desale → stummala
Severity: normal → enhancement
Summary: [RFE] implement click() method on an A tag (and other? elements) → click() method for links (and other? elements)
*** Bug 172163 has been marked as a duplicate of this bug. ***
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs
An a-element should have a click()-method. It's not an enhancement (see earlier
post).

Please change the severity to normal (or higher).

This bug is a year old now.
I encountered this as well, and stupidly threw together a sample HTML page
before searching the bug database first:

http://xaotec.com/bugs/mozilla/missing-click-method.html

oh well... maybe my sample will be of use in tracking it down.

I guess I'll just vote for it and move on.

FYI, all other methods in the spec are available, the only missing one is
'click'... which is really odd, since its been around for the longest time.
*** Bug 28391 has been marked as a duplicate of this bug. ***
*** Bug 283436 has been marked as a duplicate of this bug. ***
This is an enhancement, since it is an extension of the dom html spec, see:
http://www.w3.org/TR/2000/WD-DOM-Level-2-HTML-20001113/html.html#ID-48250443
There is no mentioning of a click() method on a HTMLAnchorElement.
Component: DOM: Core → DOM: Core & HTML
QA Contact: stummala → general
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583514
You need to log in before you can comment on or make changes to this bug.