Default additional_images alignment should be top right

VERIFIED FIXED in Firefox -esr60

Status

P1
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: mconca, Assigned: ntim)

Tracking

({regression})

unspecified
mozilla63
regression

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr6062+ verified, firefox61 unaffected, firefox62+ verified, firefox63+ verified)

Details

(Whiteboard: [blocking-static-themes-fx][ntim-intern-project] )

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
Bug 1443561 fixed the alignment of additional_images to be relative to the toolbox, but introduced a new bug causing additional_images to now be aligned to the "left top".  Prior to that patch landing, images were always aligned to the "right top".

The expectation is that all theme backgrounds, headerURL and additional_images, are aligned "top right" in the absence of any additional_backgrounds_alignment key.
(Reporter)

Updated

5 months ago
Flags: needinfo?(ntim.bugs)
Priority: -- → P1
(Assignee)

Updated

5 months ago
Blocks: 1443561
Flags: needinfo?(ntim.bugs)
status-firefox61: --- → unaffected
status-firefox62: --- → affected
status-firefox63: --- → affected
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → affected
tracking-firefox62: --- → +
tracking-firefox63: --- → +
tracking-firefox-esr60: --- → 62+
Keywords: regression
(Assignee)

Updated

5 months ago
Assignee: nobody → ntim.bugs
(Assignee)

Updated

5 months ago
Whiteboard: [blocking-static-themes-fx][ntim-intern-project]
(Assignee)

Comment 1

5 months ago
Created attachment 9003877 [details] [diff] [review]
Make additional_backgrounds_alignment default to right top
Attachment #9003877 - Flags: review?(dao+bmo)
Attachment #9003877 - Flags: review?(dao+bmo) → review+
(Assignee)

Updated

5 months ago
Keywords: checkin-needed

Comment 2

5 months ago
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a668b1f8527b
Make additional_backgrounds_alignment default to right top. r=dao
Keywords: checkin-needed

Comment 3

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a668b1f8527b
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox63: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63

Comment 4

5 months ago
Verified fixed in Nightly 63.0a1 (20180826220129) with Win10x64 and macOS High Sierra 10.13.2

Installed theme: https://addons-dev.allizom.org/en-US/firefox/addon/st-no-align-recheck/
Status: RESOLVED → VERIFIED

Updated

5 months ago
status-firefox63: fixed → verified

Comment 5

5 months ago
Created attachment 9004138 [details]
fixed_-_default_top_right_align.png
(Assignee)

Comment 6

5 months ago
Comment on attachment 9003877 [details] [diff] [review]
Make additional_backgrounds_alignment default to right top



Approval Request Comment
[Feature/Bug causing the regression]: bug 1443561
[User impact if declined]: Behaviour change in theme API
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: already done 
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: low risk
[Why is the change risky/not risky?]: simple change
[String changes made/needed]: none
Attachment #9003877 - Flags: approval-mozilla-esr60?
Attachment #9003877 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 9003877 [details] [diff] [review]
Make additional_backgrounds_alignment default to right top

Fixes a regression from bug 1443561. Approved for 62 RC1 and ESR 60.2.
Attachment #9003877 - Flags: approval-mozilla-release+
Attachment #9003877 - Flags: approval-mozilla-esr60?
Attachment #9003877 - Flags: approval-mozilla-esr60+
Attachment #9003877 - Flags: approval-mozilla-beta?

Comment 9

5 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr60/rev/a8e3e6431942
status-firefox-esr60: affected → fixed

Comment 10

5 months ago
Verified fixed with Firefox 62.0 (20180827144429) with Win10x64 and macOS High Sierra 10.13.2.

Updated

5 months ago
status-firefox62: fixed → verified
status-firefox-esr60: fixed → verified
Flags: qe-verify+ → qe-verify-

Comment 11

5 months ago
Forgot to mention in the last comment that the issue is verified also with Firefox 60.2.0esr (20180827170958)

Updated

5 months ago
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.