Closed Bug 1486213 Opened 6 years ago Closed 6 years ago

Accessibility setting to see passwords

Categories

(Core :: Layout: Form Controls, enhancement)

61 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 502258

People

(Reporter: erwinm, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

I know it's standard practice to hide passwords.


Actual results:

This can be a problem for clumsy users-- we can't tell where to correct our typos if we can't se ou typos-- and for any users if caps lock gets turned on, or scripts get switched, without any indication on the keyboard.


Expected results:

If I could check the screen after typing my password, I could check whether I've mis-typed it and how.
Bug 502258 already exists for UI to show typed passwords. I think that's more likely to be implemented than a hidden setting to always show passwords. Several add-ons provide the feature:
https://addons.mozilla.org/firefox/addon/showhide-passwords/
https://addons.mozilla.org/firefox/addon/see-my-passwords/
https://addons.mozilla.org/firefox/addon/show-me-the-passsword/
https://addons.mozilla.org/firefox/addon/password-toggler/

Bug 259059 is for a Caps Lock indicator.
Severity: normal → enhancement
Component: Untriaged → Layout: Form Controls
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Yeah, I think this is effectively a duplicate of bug 502258.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.