Named anchors have style of links

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Stephen Wille Padnos, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

Named anchors (which are not links) take the hover style of links when the mouse
hovers over them.  They do not take the properties of A or A:visited.

Reproducible: Always
Steps to Reproduce:
1. Load the example page
2. Mouse over a heading in the center portion of the page (such as "Current
Release")
3. Observe that the text gets underlined when the mouse is over it, even though
it is not a link.


Expected Results:  The anchor text should remain in the style of H2, not A.

I'm not positive (I haven't been able to find a definitive answer from the CSS2
or HTML 4.01 specs) but I think that anchors should not be rendered like links,
since there is no action to be taken by clicking them.
this is not a bug, if the page writes a:hover{} this means all <a> have to
hover, no matter if this is a <a name=""> or a <a href=""> construction.
The :hover pseudo-class applies to all elements, not just links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.