Closed Bug 1486289 Opened 3 years ago Closed 2 years ago

print page to PDF does not print entire page

Categories

(Core :: Printing: Output, defect, P3)

61 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: alexander.duytschaever, Unassigned)

Details

(Keywords: parity-chrome, parity-edge)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704194937

Steps to reproduce:

1. go to https://www.celestaire.com/why-celestial-navigation/
2. select Print > Print to File
3. Print


Actual results:

The PDF (generated by the Fx built-in print utility) contains part of the content shown in the HTML page. For some reason, only a first part of the text is converted to PDF, plus surrounding stuff.


Expected results:

Entire page content is expected.
Component: Untriaged → Printing: Output
Product: Firefox → Core
I can also reproduce the print problem on Nightly63.0a1 Win10.

Chrome and Edge print the page as expected.
Status: UNCONFIRMED → NEW
Ever confirmed: true
An example where this bug does not show up is when making a PDF from https://en.wikipedia.org/wiki/Mercator_projection .

I guess this is related to interference by Javascript.
Keywords: dupeme
Priority: -- → P3

Dupe of bug 939897. Main containing div for content (two levels down inside <main> element) is flex container.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939897

I'm testing whether printing the site is fixed by bug 1622935 or not. It seems the site has changed and not contains any flex layout. I'll resolve it as WORKSFORME.

Resolution: DUPLICATE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.