Closed Bug 1486362 Opened 6 years ago Closed 3 months ago

githubuniverse.com - CPU usage is extremely high

Categories

(Web Compatibility :: Site Reports, enhancement, P3)

Unspecified
Linux
enhancement

Tracking

(Performance Impact:low, firefox63 affected)

RESOLVED WORKSFORME
Performance Impact low
Tracking Status
firefox63 --- affected

People

(Reporter: karlcow, Unassigned)

References

()

Details

This is a spin-off of https://webcompat.com/issues/12426
This page contains a lot of animations, slowly down the computer with very high cpu consumption.

Marking as a performance bug.
There are two problems causing the high cpu usage.

1) animation on #intro-icon element which is driven by script (requestAnimationFrame or setTime or some such)
2) transform animation on invisible elements (bug 1427033)
Firefox 56 and Firefox 57 are ancient unsupported versions. 
Why was this task reported instead of testing with a supported version?
Summary: CPU usage is extremely high both on Firefox 56.0 and 57.0 (Beta 8). All the other pages related to this GitHub event are having the same problem. On Chromium for Linux the CPU usage is normal. → CPU usage is extremely high at githubuniverse.com
Whiteboard: [webcompat] [qf] → [webcompat] [qf:p3:f67]
(In reply to Andre Klapper from comment #2)
> Firefox 56 and Firefox 57 are ancient unsupported versions. 
> Why was this task reported instead of testing with a supported version?

This was simply filed back when those were the latest versions, at the webcompat link in comment 0. I've clarified the summary here to not be version-specific.

Anyway -- mstange says that this is likely a result of the fact that we use software compositing on Linux for now, which is inherently slow.  (The reporter was using linux, per first comment on the original webcompat issue.)
Whiteboard: [webcompat] [qf:p3:f67] → [webcompat] [qf:p3]

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Webcompat Priority: ? → ---
Performance Impact: --- → P3
Whiteboard: [webcompat] [qf:p3] → [webcompat]
Severity: normal → S3

The layout of this site is different now, without much animation, and I can't reproduce a performance issue here anymore. Let's close this as WORSKFORME, given the comments above.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME
Whiteboard: [webcompat]
Component: Layout → Site Reports
Product: Core → Web Compatibility
Summary: CPU usage is extremely high at githubuniverse.com → githubuniverse.com - CPU usage is extremely high
Version: 57 Branch → unspecified

(In reply to Thomas Wisniewski [:twisniewski] from comment #6)

The layout of this site is different now, without much animation

archive.org has a snapshotted version from the day that this was filed, it looks like:
https://web.archive.org/web/20180826063636/https://githubuniverse.com/

When I have that in a foreground tab: after it finishes loading, my Firefox parent process seems to have a baseline CPU usage of 11% or so, and the content process for this site has 5-6% (and no other Firefox processes have CPU usage higher than those).

Chrome has similar CPU usage (7-10% for one process and 6% for another).

So I think WORKSFORME seems reasonable here. Not sure if we got better or not on this site, but we don't seem to be substantially worse than Chrome, and some persistent CPU usage makes sense given the script-driven animation noted in comment 1 here.

You need to log in before you can comment on or make changes to this bug.