Text overlaps other table elements

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: rpa_rio, Assigned: tristan)

Tracking

({testcase})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

The table elements doesn't stay on your correct position / place

Reproducible: Always
Steps to Reproduce:
1.It's simple, go to www.xmethods.com and the footer text appears at middle of
the page.


Actual Results:  I had checked the source code of page and the element is a
table after a span element.

Expected Results:  The text in the middle of the page must be in the end of the
page.

Updated

17 years ago
Summary: The table elements. → Text overlaps other table elements

Comment 1

17 years ago
Created attachment 85999 [details]
testcase

the height of the div tag is specified and is much smaller than it needs to be
to contain the table.  I added a red border to the div.  The out-of-place text
follows the div rather than table.

There doesn't seem to be anything particularly buggy about Mozilla's
behavior...
Evang?

Comment 2

17 years ago
shows up with linux build 20020602
OS=>All
marking NEW.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows 98 → All

Comment 3

17 years ago
I think this is evang -- the relevant part of the CSS specs is 
http://www.w3.org/TR/REC-CSS2/visufx.html#overflow-clipping  (Notice the 
example -- a BLOCKQUOTE that's too big for its DIV.)

The overflow property determines what happens when a box's content is bigger 
than the box.  The initial value is "visible", which means the content renders 
outside of the box.  In this bug's case, since the DIV is absolutely sized, the 
content shouldn't affect the DIV's size or the position of the next element 
after the DIV.

Opera shows the same behavior as Mozilla.  IE, on the other hand, expands the 
DIV to be large enough to completely contain its contents.  I think the page is 
relying on IE's incorrect behavior...

Updated

17 years ago
Priority: -- → P3
-> Evang
Assignee: attinasi → nitot
Component: Layout → African
Product: Browser → Tech Evangelism
QA Contact: petersen → momoi
Version: other → unspecified
Hardware: PC → All
page got fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
us general for now
Component: African → US General
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.