Closed Bug 1486467 Opened 6 years ago Closed 6 years ago

[webdriver] Get rid of camel-case for pageLoad and sessionId

Categories

(Testing :: geckodriver, enhancement, P2)

Version 3
enhancement

Tracking

(firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

Attachments

(2 files)

Instead use `page_load` and `session_id`. `pageLoad` and `sessionId` should only be used for serialization and deserialization with Serde.
Attachment #9004220 - Flags: review?(ato)
Attachment #9004222 - Flags: review?(ato)
Comment on attachment 9004220 [details] [diff] [review]
[webdriver] Rename sessionId to session_id for NewSessionResponse

Review of attachment 9004220 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/webdriver/src/response.rs
@@ +77,4 @@
>      pub fn new(session_id: String, capabilities: Value) -> NewSessionResponse {
>          NewSessionResponse {
>              capabilities: capabilities,
> +            session_id: session_id,

With the renaming of sessionId, this can now be written like this
too:

> NewSessionResponse { capabilities, session_id }

Not a required change, but just saying for future reference.
Attachment #9004220 - Flags: review?(ato) → review+
Attachment #9004222 - Flags: review?(ato) → review+
(In reply to Andreas Tolfsen ﹝:ato﹞ from comment #4)
> ::: testing/webdriver/src/response.rs
> @@ +77,4 @@
> >      pub fn new(session_id: String, capabilities: Value) -> NewSessionResponse {
> >          NewSessionResponse {
> >              capabilities: capabilities,
> > +            session_id: session_id,
> 
> With the renaming of sessionId, this can now be written like this
> too:
> 
> > NewSessionResponse { capabilities, session_id }
> 
> Not a required change, but just saying for future reference.

Oh, I haven't known that. I will make this change.
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b4cb950d23e5
[webdriver] Rename pageLoad to page_load for TimeoutsResponse. r=ato
https://hg.mozilla.org/integration/mozilla-inbound/rev/9d702b7e5d80
[webdriver] Rename sessionId to session_id for NewSessionResponse. r=ato
https://hg.mozilla.org/mozilla-central/rev/b4cb950d23e5
https://hg.mozilla.org/mozilla-central/rev/9d702b7e5d80
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: